Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    fabbiosilent's Avatar
    iPhone Nanite

    2 Posts

    Default ipod touch 2g in recovery mode loop

    Hi everybody,
    i think i've done some big mess with my ipod touch 2G. It started when i wanted to erase all data and apps on (jailbroken) iOS v3.1.3. I tried to that using "Settings > General > Reset > Erase All Content and Settings" on the ipod. After that, ipod went stuck on apple logo (rebooting?). After waiting some time, i decided to turn it off and on. That only switched the original apple logo to the "ananas" logo.

    Then i tried to jailbreak it again using redsn0w v0.9.5b5-5 and iPod2,1_4.0_8A293_Restore.ipsw. Installation went fine except ipod doesn't reboot, instead goes automatically in recovery mode.

    Searching around i found this is called recovery mode loop, and found a guide using irecovery to fix it. i followed it (snow leopard user), but it didnt solve the problem. Btw, here's what i got by executing iRecovery:
    iRecovery - Recovery Utility for 0x1281 and WTF.
    by wEsTbAeR-- and Tom3q
    Got USB
    :: iBoot for n72ap, Copyright 2009, Apple Inc.
    ::	BUILD_TAG: iBoot-636.66
    ::	USB_SERIAL_NUMBER: CPID:xxxx CPRV:xx CPFM:xx SCEP:xx BDID:00 ECID:xxxxxxxxxxxxxxxx IBFL:01 SRNM:[xxxxxxxxxxxx]
    [FTL:MSG] Apple NAND Driver (AND) RO
    [FIL:INF] Found chip id 0x3ed5d72c on CS 0.
    [FIL:INF] Found chip id 0x3ed5d72c on CS 1.
    [FTL:MSG] FIL_Init            [OK]
    [FTL:MSG] UF_Init            [OK]
    [FTL:MSG] FPart Init          [OK]
    read new style signature 0x43313134 (line:375)
    [FTL:MSG] VSVFL Register  [OK]
    [FTL:MSG] VFL Init            [OK]
    [FTL:MSG] VFL_Open            [OK]
    [FTL:MSG] YAFTL Register  [OK]
    yaFTL::YAFTL_Open(l:2630): CXT is not valid . Performing full NAND R/O restore ...  
    [FTL:MSG] FTL_Open            [OK]
    Boot Failure Count: 15	Panic Fail Count: 0
    Entering recovery mode, starting command prompt
    (Recovery) iPhone$ setenv auto-boot true
    (Recovery) iPhone$ saveenvs
    (Recovery) iPhone$ fsboot
    (Recovery) iPhone$ reboot
    (Recovery) iPhone$ exit                    
    Closing USB connection...
    Anyone can help me?? I would be fine just by getting it back to an unjailbroken state….i've done extensive searchs but i can't fix this on my own…

    Last edited by fabbiosilent; 09-26-2010 at 07:27 AM.
  2. #2  
    myzhi's Avatar
    iPhone Intermediate

    366 Posts


    Try using Tinyumbrella to kick it out of recovery mode after restore.

    Next time, don't use erase all... That removes everything on phone, including the OS.
  3. Thread AuthorThread Author   #3  
    fabbiosilent's Avatar
    iPhone Nanite

    2 Posts


    thanks man,
    it worked out pretty good =)

    too bad i couldn't find tinyumbrella before!

Posting Permissions