1. Darthstorm528's Avatar
    I've been just the opposite. When I had the Fahrenheit app, it took forever to update the badge. I've had no problems with BeWeather most of the time. A couple of times it was behind a bit. It seems all the temp badge apps have this issue to some degree. But BeWeather and eWeather HD have been the best.


    Sent from my ancient but trustworthy iPhone 5.
    That has been my experience as well. Temp-badges are finicky. But now with the widget-ability of iOS 8 the temp-badge is less important to me.
    I never used the Temp Badge because I was never a Fan. The widgets in iOS 8 is a high welcome as I rather use them over temp badges, due in part as I was also an Android user and also the fact that you had to have the App refresh running when using the temp badge. I have that feature turned off
    11-18-2014 05:50 PM
  2. TurboTiger's Avatar
    The temperature badge should update roughly every hour.

    Make sure to never close BeWeather from the app switcher by swiping it up. This will kill any background processes (the one updating the badge).
    pfluger,
    Is this something new?
    I didn't know I had to have BeWeather in the app switcher for the badge to update.
    Perhaps this is why it never updated even with the previous version several months ago.
    Is this something you're working so that we no longer have to have it in the app switcher for the badge to update?
    I assume it's a minimal drain on the battery.
    TIA
    11-18-2014 06:42 PM
  3. Trees's Avatar
    Yes. I have the background app refresh on, just as i did when I first installed the app yesterday, and then upon reinstalling today I made sure it was on for both the iPad and iPhone.

    And...I've spoken too soon. My 5S hasn't updated the temp since 3pm but at least the badge didn't disappear on me lol.

    I wound up having to reopen the app altogether on my iPad & 5S to get things going again.

    Either way, I'm real happy with the app overall, and I use the Notification Center to check on things through out the day anyway, so I will see the current temp updated there every time I open it, and that's fine. If the badge still stays fussy on my iPad and iPhone I'll just toggle it off.


    tapped out by my P!NK fingers on my GORGEOUS GOLD 5S
    I had the same problem as you and AppleNick have reported. Widget is updating, yet no change in the badge icon all day. I tried opening the app thinking that would trigger a refresh.

    While at home this evening I noticed that the temp number went away from the badge icon. I did a power cycle and the icon with temp number is back.

    Digging in further, I see that yesterday morning @ 08:22:05hrs (Launch Time) BeWeather2Widget crashed with:

    Exception Type: EXEC_CRASH (SIGABRT)
    Exception Subtype: LAUNCH_HANG
    Exception Message: The extension took too much time to initialize Triggered by Thread: 0

    I also see a JetsamEvent @ 08:22:05hrs for yesterday morning. BeWeather2 is tagged as the Largest process.

    I don't know if there is any correlation with the two, but perhaps after the crash BeWeather wasn't fully functional, and thus the icon badge temp didn't work until the power cycle this evening.

    I also wonder if a JetsamEvent triggered the BeWeather2 exception. I say this as my understanding is that the JetsamEvent is a process by which iOS "culls" inactive memory or "freezes" the memory pages that are mapped to running apps (processes) that have been deemed "inactive" by iOS. I could be completely wrong here, so welcome anyone who has more clarity about JetsamEvent. Google searches didn't yield a meaningful definition (plenty of complaints, but not real technical details).
    11-18-2014 06:55 PM
  4. CDG's Avatar
    Mine was updating fine until just now the temp badge disappeared.

    I opened the app and it came back on.

    Weird!


    Sent from my iPhone 6 using Tapatalk
    11-18-2014 07:03 PM
  5. Ledsteplin's Avatar
    pfluger,
    Is this something new?
    I didn't know I had to have BeWeather in the app switcher for the badge to update.
    Perhaps this is why it never updated even with the previous version several months ago.
    Is this something you're working so that we no longer have to have it in the app switcher for the badge to update?
    I assume it's a minimal drain on the battery.
    TIA
    That's why they're called "Background Apps". Nothing new about that. All apps used are in the "app switcher". Not all are running in the background though. Just don't flick it out. I never close out apps in the app switcher, unless there's an issue like the messages app freezing up. It's harder on the battery to always delete all the apps in the background.


    Sent from my ancient but trustworthy iPhone 5.
    TurboTiger and pfluger like this.
    11-18-2014 07:04 PM
  6. Ledsteplin's Avatar
    Mine was updating fine until just now the temp badge disappeared.

    I opened the app and it came back on.

    Weird!


    Sent from my iPhone 6 using Tapatalk
    Mine did that once, but I can't recall why. It was something I did. When it comes to computers and techie things, nothing is perfect.


    Sent from my ancient but trustworthy iPhone 5.
    11-18-2014 07:11 PM
  7. TurboTiger's Avatar
    Ledsteplin,
    You and I both use another weather app that doesn't need to be in the app switcher for it to update the badge icon.
    That's why I was a bit surprised when pfluger mentioned it
    Regardless, I will use BeWeather which ever way I need to for it to work
    .
    Good Luck
    Spencerdl likes this.
    11-18-2014 07:14 PM
  8. bamf-hacker's Avatar
    Make that 16 5 ️ reviews. Just put mine in. BeWeather2 is my new main page weather app!

    Kind of sad I could not get in on the beta due to device obligations that prevent me from using beta software but it is well worth my $$$
    ladyc0524, Spencerdl and pfluger like this.
    11-18-2014 07:38 PM
  9. blueszz's Avatar
    Just purchased it and left another 5 star review.

    Congrats with this great app @pfluger!
    It was amazing to see how you worked with the feedback you got on imore ☺

    Here is my current layout.
    Attached Thumbnails BeWeather 2 for iPhone-uploadfromtaptalk1416361892797.png   BeWeather 2 for iPhone-uploadfromtaptalk1416361907554.png  
    pfluger and Spencerdl like this.
    11-18-2014 07:52 PM
  10. TurboTiger's Avatar
    You guys are making me jealous.
    I'm gonna have to be more creative and dress up my themes / icon set.
    Good work to all.
    Good Luck
    11-18-2014 07:59 PM
  11. Ledsteplin's Avatar
    Ledsteplin,
    You and I both use another weather app that doesn't need to be in the app switcher for it to update the badge icon.
    That's why I was a bit surprised when pfluger mentioned it
    Regardless, I will use BeWeather which ever way I need to for it to work
    .
    Good Luck
    You mean with Background App Refresh on. They all show in the App switcher. And some run without background app refresh on. They don't all work the same way. Weather Underground is different in many ways. And that's where BeWeather 2 gets it's info and stuff. What's odd is none of the personal weather stations I have give a "feels like" temp. Many don't. But some in other areas do. I don't know the reason for that. But "feels like" is always the same as the current temp. I have seen it different a couple times on BeWeather. But it's usually the same. It's like that on weather underground too. I emailed wunderground and asked about it. No reply.


    Sent from my ancient but trustworthy iPhone 5.
    TurboTiger likes this.
    11-18-2014 08:11 PM
  12. kruegs's Avatar
    Same issue as others... everything with the exception of the temp badge seems to function great. I hope that the badge icon issues can get resolved as that is a great feature. Until that time... I am turning it off.
    11-19-2014 08:36 AM
  13. ctt1wbw's Avatar
    Cray cray adorbs!!! Holy crap, and all the icons too!!! Shibby!!!!
    Spencerdl likes this.
    11-19-2014 09:12 AM
  14. bdtrader's Avatar
    11-19-2014 09:30 AM
  15. ctt1wbw's Avatar
    Okay, so where are the extra sites to go to and get more icon sets?
    Spencerdl likes this.
    11-19-2014 09:56 AM
  16. Spencerdl's Avatar
    Okay, so where are the extra sites to go to and get more icon sets?
    This is a very good idea. I remember there was such a site for BlackBerry (Themes in Motion), but one for Apple would be VERY NICE....SMILE
    11-19-2014 10:43 AM
  17. Spencerdl's Avatar
    Nice find, now for iMore to introduce the new BeWeather2 (hint, hint)...Smile
    CDG and robertk328 like this.
    11-19-2014 10:44 AM
  18. CDG's Avatar
    Same issue as others... everything with the exception of the temp badge seems to function great. I hope that the badge icon issues can get resolved as that is a great feature. Until that time... I am turning it off.
    The temp badge on my iPhone disappeared again and the one on my iPad didn't update since last night.

    The app is so wonderful, hope this gets taken care of soon.


    Sent from my iPhone 6 using Tapatalk
    11-19-2014 11:09 AM
  19. tharley46's Avatar
    Same here charlyee, also the temp doesn't update on the icon, I thought it would. I have app refresh on for that app also.


    Sent from my iPad using Tapatalk
    11-19-2014 11:19 AM
  20. Ledsteplin's Avatar
    The temp badge on my iPhone disappeared again and the one on my iPad didn't update since last night.

    The app is so wonderful, hope this gets taken care of soon.


    Sent from my iPhone 6 using Tapatalk
    I don't have much of an issue with my badge. An occasional blip. Like this morning when I opened my phone, it said 1. I knew it was cold, but not that cold. And the weather stations don't all say the same thing. One said 17. Another said 23. The airport said 24. I use the airport as a second local location. Have you tried turning the badge off, then back on?


    Sent from my ancient but trustworthy iPhone 5.
    11-19-2014 11:23 AM
  21. ThePinkChameleon's Avatar
    The temp badge on my iPhone disappeared again and the one on my iPad didn't update since last night.

    The app is so wonderful, hope this gets taken care of soon.


    Sent from my iPhone 6 using Tapatalk
    Same here charlyee, also the temp doesn't update on the icon, I thought it would. I have app refresh on for that app also.


    Sent from my iPad using Tapatalk
    I'm still having these issues on both iPad Air 1st gen and my 5S, both on iOS 8.1.1.

    Sometimes the badge will disappear, most times it won't update.

    I love this app so hopefully this can be addressed in a future update !!

    I don't have much of an issue with my badge. An occasional blip. Like this morning when I opened my phone, it said 1. I knew it was cold, but not that cold. And the weather stations don't all say the same thing. One said 17. Another said 23. The airport said 24. I use the airport as a second local location. Have you tried turning the badge off, then back on?


    Sent from my ancient but trustworthy iPhone 5.
    I've tried everything to correct the badge not updating or disappearing and nothing has helped. It will correct itself for a short time, but then play the same reindeer games again. Lol.


    tapped out by my P!NK fingers on my GORGEOUS GOLD 5S
    11-19-2014 11:32 AM
  22. Spencerdl's Avatar
    Has anyone figured out how to download a custom set with the right HTTP url?? If so could you pass on that info.
    11-19-2014 06:42 PM
  23. HankAZ's Avatar
    Has anyone figured out how to download a custom set with the right HTTP url?? If so could you pass on that info.
    The icons go in a .zip file that is renamed to .bwi. The URL Is the URL to access the file. I put a set in my Dropbox and used the 'public URL'.

    https://dl.dropboxusercontent.com/u/8942924/h.bwi
    11-19-2014 08:06 PM
  24. Spencerdl's Avatar
    THANKS to Hank for all his help
    BeWeather 2 for iPhone-imageuploadedbytapatalk1416454527.102329.jpg
    BeWeather 2 for iPhone-imageuploadedbytapatalk1416454537.084062.jpg


    Sent from my GOLD s
    using Tapatalk
    pfluger likes this.
    11-19-2014 09:35 PM
  25. pfluger's Avatar
    Thanks Pfluger. So since reinstalling both on iPad and iPhone this morning, the badge was updating and "behaving". But now(4pm) I've noticed on my iPad the temp hasn't updated since 2pm and the badge disappeared altogether about 3pm. So far my 5S seems to be ok.

    As far as keeping the app active in the background, I've left it alone yesterday and then today since installing it. I hardly ever close out my apps in the switcher, but I know I didn't close BeWeather yesterday or today when I started having the disappearing badge and not updating the temp.

    FWIW, I know I have a good wifi connection because I've been streaming iHeartRadio on my iPad since 9am without any cut outs.

    Any other suggestions?


    tapped out by my P!NK fingers on my GORGEOUS GOLD 5S
    We don't know if the problem is because BeWeather fails to set the badge or it fails to run at all in the background. We will add something to an upcoming beta that will help to figure it which one it is.
    ThePinkChameleon likes this.
    11-19-2014 10:31 PM
2,235 12345 ...

Similar Threads

  1. iPhone 6 price in the US
    By Abk92 in forum iPhone 6
    Replies: 6
    Last Post: 01-22-2015, 12:38 PM
  2. King Of Ring | Adventure Game | Promo Codes Available For FREE
    By baagansmith in forum iPhone Apps & Games
    Replies: 11
    Last Post: 12-04-2014, 03:06 AM
  3. iPhone 6/6 Plus
    By TripleOne in forum iPhone 6
    Replies: 14
    Last Post: 11-17-2014, 06:02 PM
  4. Replies: 4
    Last Post: 11-17-2014, 07:59 AM
  5. Replies: 1
    Last Post: 11-17-2014, 05:48 AM
LINK TO POST COPIED TO CLIPBOARD