Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    citibori's Avatar
    iMore Beginner

    82 Posts

    Default iMovie app

    I went to download the iMovie app and it tells me that my firmware is incompatible. I am on 4.2.1 and it tells me that I have to be on 4.2.6 which is the Verizon one. Can anyone shed some light on this?
  2. #2  
    Alli's Avatar
    iMore Genius

    10,934 Posts
    Global Posts
    13,726 Global Posts


    Simple - if you're a gsm user, update to 4.3.x which is the latest gsm firmware, or update to 4.2.6 if you're with VZW, or don't use iMovie.

Posting Permissions