1. DerKane's Avatar
    Hi Guys,

    Yesterday I moved carrier from EE to Three (UK).

    Since then I've been getting invalid SIM issues every few hours, is this likely to be a faulty SIM or is this a problem with swapping SIMs?

    I've read some saying network resetting helps, others say a wipe and start again is best, I'm not quite sure.

    Cheers,

    Matt
    11-16-2016 01:27 AM
  2. ritesh's Avatar
    Have you inserted the new sim? If that is giving the error, check porting status. Maybe the transition hasn't happened yet.
    11-16-2016 02:50 AM
  3. TwitchyPuppy's Avatar
    Try resetting network settings. If that doesn't work, get your SIM card replaced.
    11-16-2016 05:27 AM
  4. DerKane's Avatar
    Have you inserted the new sim? If that is giving the error, check porting status. Maybe the transition hasn't happened yet.
    Port had finished by midday but I'm wondering if they'd been doing SIM updates during the day.

    Try resetting network settings. If that doesn't work, get your SIM card replaced.
    Will do, it's not happened so far today so that could be a good sign it was to do with the porting service.
    11-16-2016 05:29 AM
  5. DerKane's Avatar
    Try resetting network settings. If that doesn't work, get your SIM card replaced.
    Happened again last night, reset network settings.

    If it's still happening again I'll speak to my carrier about a new SIM.
    11-17-2016 04:12 AM

Similar Threads

  1. SIM card tray - same for iPhone 6 and 7?
    By DCMMID in forum Ask a Question
    Replies: 1
    Last Post: 11-15-2016, 07:30 PM
  2. Comic: The Ever-Changing Definition of "Pro"
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 11-15-2016, 08:12 AM
  3. Where is the nano-sim on the iPhone 6s
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 11-14-2016, 09:53 PM
  4. Replies: 3
    Last Post: 11-14-2016, 08:15 PM
  5. Replies: 0
    Last Post: 11-14-2016, 10:32 AM
LINK TO POST COPIED TO CLIPBOARD