1. jono119's Avatar
    Anyone else getting horrible signal on their 7 Plus?

    I am on Verizon and came from a 6s Plus and now using a 7 Plus (JB 256GB) - signal is not as good and switches back and forth between LTE and 3G.. sometimes 1x.

    My boss has AT&T and came from a 6 Plus and now using a 7 Plus (B 128GB) - his signal is horrible as well.

    On both providers, the service was great in the Houston Metro Area.

    Is it the phone or the software?

    Thanks in advanced.
    09-29-2016 08:38 AM
  2. TJ_MAN's Avatar
    I have also noticed the same thing. I am on Verizon and came from the 6s plus and have noticed the the 7 plus switching to 3G way more than my 6S plus ever did.
    09-29-2016 09:15 AM
  3. o4liberty's Avatar
    I am on AT&T with no issues
    09-29-2016 10:20 AM
  4. Hermdroid's Avatar
    Same with Verizon in my area. Maybe needs some kind of carrier setting update or something.
    09-29-2016 11:21 AM
  5. jono119's Avatar
    On AT& T iphone we had to switch the cellular data LTE to only on Data, so when he makes phone calls it switch over to 4G with full signal.
    09-29-2016 11:38 AM
  6. Craig's Avatar
    Still having issues with AT&T since going to iOS 10. I am not saying it's an iPhone 7 issue, but an iOS issue, because we're seeing it with AT&T on the 6 and the 7.
    o4liberty likes this.
    09-29-2016 02:36 PM
  7. mach1man's Avatar
    I've seen this multiple times on the apple help forum. I'm experiencing it too. What I've found is it happens when I have the wifi on and I'm not near a known wifi spot. Like if I leave work while connected to the wifi. Once I get out of the zone it hops around looking for signal. I went one day using LTE only and didn't notice the issue.

    I'm on Verizon with the 7+ 128GB matte black
    09-29-2016 04:02 PM
  8. Hermdroid's Avatar
    I've seen this multiple times on the apple help forum. I'm experiencing it too. What I've found is it happens when I have the wifi on and I'm not near a known wifi spot. Like if I leave work while connected to the wifi. Once I get out of the zone it hops around looking for signal. I went one day using LTE only and didn't notice the issue.

    I'm on Verizon with the 7+ 128GB matte black
    I only seen it once but you might be on to something. I had that same issue when I was leaving my house for work this morning.
    09-29-2016 04:03 PM
  9. eyecrispy's Avatar
    On AT& T iphone we had to switch the cellular data LTE to only on Data, so when he makes phone calls it switch over to 4G with full signal.
    I posted this in another thread last weekend, but I was unable to send any SMS while I was out and about. It only started working again when I turned off LTE for voice, which I never had issues with prior to the 7. That evening while I was at home, I turned LTE back on for both voice and data and things have been normal since then, but I'm not sure what the heck happened while I was out. Frustrating.
    09-29-2016 04:27 PM
  10. erwaso's Avatar
    No issues on AT&T versus my wife's 6s
    09-30-2016 12:52 PM
  11. Sooks's Avatar
    I am having the exact same issue with my 7+. When sitting at my desk at work I would typically get between 3 and 4 bars (circles) with my 6+ and with my 7+ I only get 1 to 2. Really annoying as my calls would drop and have issues, luckily wifi calling fixed that but still noticeable.
    09-30-2016 12:56 PM
  12. Hardbodyhero's Avatar
    Verizon outage or service down? Current problems and outages | Down Detector

    You guys can use this site to check on network related issues, but it could be a phone issue too, no telling.
    09-30-2016 01:46 PM
  13. kgyamerah's Avatar
    Yes I was having the same issue with my iPhone 7 plus 256GB,when I contacted apple they advise me to contact my network provide which is three UK.But what I did was to remove my SIM card while the phone is still on and inserts it again,problem solved .My LTE is perfectly working now.
    09-30-2016 02:45 PM
  14. jneusch's Avatar
    I am having the same issue on VZ.
    09-30-2016 05:05 PM
  15. eyecrispy's Avatar
    I've dropped at least 4 calls (ATT) today in places where I'm usually ok. It has been frustrating. I didn't have this issue with my 6s and SE.
    09-30-2016 05:19 PM
  16. krazyatom's Avatar
    Well I don't have iPhone 7 yet but my SE signal is worst after ios 10 and i have tmobile. Not sure if it's related.
    libra89 likes this.
    09-30-2016 05:29 PM
  17. libra89's Avatar
    Well I don't have iPhone 7 yet but my SE signal is worst after ios 10 and i have tmobile. Not sure if it's related.
    Same here. I don't get it. :/
    09-30-2016 11:14 PM
  18. Rocket_Girl's Avatar
    I have also noticed the same thing. I am on Verizon and came from the 6s plus and have noticed the the 7 plus switching to 3G way more than my 6S plus ever did.
    My 6+ did this often; so did SE. Better now w/ 7+ -but think that may be more about carrier/infrastructure than device: couple of carrier setting updates more recently.
    libra89 likes this.
    10-01-2016 08:03 AM
  19. jsntrenkler's Avatar
    I am on AT&T and have not noticed any difference. I have the 7 plus coming from a 6s Plus.
    10-01-2016 09:14 AM
  20. erwaso's Avatar
    Reset network settings maybe?
    10-01-2016 10:00 AM

Similar Threads

  1. iphone se signal bands
    By mark993 in forum iPhone SE
    Replies: 8
    Last Post: 10-02-2016, 05:31 PM
  2. Replies: 19
    Last Post: 09-30-2016, 01:48 PM
  3. Numbers instead of signal bars??
    By emscapt47 in forum iPhone 6 Plus
    Replies: 3
    Last Post: 09-26-2016, 09:37 AM
  4. Replies: 1
    Last Post: 09-15-2016, 09:15 AM
  5. how do you turn off the signal bell beep in iMessage ?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 09-14-2016, 06:26 PM
LINK TO POST COPIED TO CLIPBOARD