Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    ssjmec's Avatar
    iMore Nanite

    7 Posts
    Global Posts
    92 Global Posts

    Default My Compass app doesn't seem to work when I set it to True North.

    Hey guys, I just would like to ask you what could be the problem on my 6s. My compass app is not working when I set the true north to on. It is just frozen while pointing to north. When I turn off true north and restart the compass app, it works no problem.

    I already tried turning location to off and on, and as well as doing a hard reset. What else could I try to do aside from restoring it?

    PS: Another question, if I back up to iTunes and restored backup, due to ios 9 app thinning, apps wont be backed up unlike in iOS 8, is this right? So I need to redownload everything again?

  2. #2  
    Ariel Babalao's Avatar
    iMore Expert

    786 Posts

    Default Re: Compass Problem

    This is a late reply, but if you haven't solve the problem with the compass here you go.
    True north in compass require the need of active data connection in order to work regardless to wether you have data or not. Go to settings> cellular> compass> on/
    Make sure compass is also turned on in location service which is also turned on. Now your true north should work just fine.
    I don't understand your question about iTunes. However, if you backup your iPhone when it was having iOS 8, you can restore that backup on your iPhone after upgrading to iOS 9 and all your apps, data will be restore the way there used to be on your iPhone under iOS 8. You can later on go ahead and do backups of your iPhone iOS 9 again without any issue too.
  3. #3  
    Larry Cook1's Avatar
    iMore Intermediate

    484 Posts

    Default Re: Compass Problem

    Thanks Ariel babalao for that info. I didn't even realize that mine wasn't working. I turned off true north and toggled back on and now it works fine. Thanks again.

Similar Threads

  1. IOS 9.2 and Apple Earbud Switch Problem
    By owlyn in forum iOS 9
    Replies: 3
    Last Post: 01-21-2016, 01:25 PM
  2. Having a problem with installing iemulator!
    By panele01 in forum iPhone 4
    Replies: 9
    Last Post: 12-28-2015, 04:40 AM
  3. My iMac is running hotter than usual, what could the problem be?
    By Rafagon in forum OS X El Capitan (10.11)
    Replies: 1
    Last Post: 12-19-2015, 11:40 AM
  4. Replies: 0
    Last Post: 12-18-2015, 05:34 AM
  5. Replies: 0
    Last Post: 12-14-2015, 11:02 AM

Posting Permissions