Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
  1. Thread AuthorThread Author   #1  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Birthday Alert Issue

    So I have birthdays from contacts in my calendar. I have the default notifications on birthdays set to "None" in the settings because I just want to see that someone has a birthday, not be full on alerted to it. Anyway, I can't get it to stop alerting me two days before the birthday at 9:00 am. Anyone know what to do here?
  2. #2  
    JustMe'D's Avatar

    Posts
    20,049 Posts
    Global Posts
    20,279 Global Posts
    iOS Version
    7.0.4

    Default Re: Birthday Alert Issue

    On your device, go to Settings-Mail, Contacts, Calendars and then scroll sown to the Calendars section and select "Default Alert Times". Tap on "Birthdays" and make the necessary changes.
    Thanked by:
    bradenfontaine (02-28-2013)
  3. Thread AuthorThread Author   #3  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Birthday Alert Issue

    That's the thing, the default time is already set to "None". So I shouldn't be getting these alerts.
  4. #4  
    JustMe'D's Avatar

    Posts
    20,049 Posts
    Global Posts
    20,279 Global Posts
    iOS Version
    7.0.4

    Default Re: Birthday Alert Issue

    Quote Originally Posted by Wildo6882 View Post
    That's the thing, the default time is already set to "None". So I shouldn't be getting these alerts.
    You're right. You shouldn't be getting the alerts. Is it possible that Facebook or any other social network you may have is set to alert you in advance?
  5. Thread AuthorThread Author   #5  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Birthday Alert Issue

    Quote Originally Posted by JustMe'D View Post
    You're right. You shouldn't be getting the alerts. Is it possible that Facebook or any other social network you may have is set to alert you in advance?
    Nope. Don't let Facebook sync contacts. I have no idea why it's doing it. I just got a replacement due to a blown speaker and had to use IMAP setting for Gmail now, but I removed contacts birthdays from the calendar and only use the iCloud ones.
  6. #6  
    tech_fan's Avatar
    iMore Newbie

    Posts
    38 Posts
    Global Posts
    220 Global Posts

    Default Re: Birthday Alert Issue

    Quote Originally Posted by Wildo6882 View Post
    That's the thing, the default time is already set to "None". So I shouldn't be getting these alerts.

    Try powering the phone off and then turn it back on again to see if that solves it. Whenever my phone acts quirky, powering it off and back on again fixes it.
  7. Thread AuthorThread Author   #7  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Birthday Alert Issue

    So I think it's something to do with the Gmail issue. For some reason it has all my gmail contact birthdays even though it doesn't have my contacts synced (all contacts are through iCloud). So they're actually listed in there twice. Guess I'll probably have to remove my contact birthdays from my gmail calendar. I think that's actually the issue.
  8. #8  
    JustMe'D's Avatar

    Posts
    20,049 Posts
    Global Posts
    20,279 Global Posts
    iOS Version
    7.0.4

    Default Re: Birthday Alert Issue

    Quote Originally Posted by Wildo6882 View Post
    So I think it's something to do with the Gmail issue. For some reason it has all my gmail contact birthdays even though it doesn't have my contacts synced (all contacts are through iCloud). So they're actually listed in there twice. Guess I'll probably have to remove my contact birthdays from my gmail calendar. I think that's actually the issue.
    To fix your duplicate entries in your contacts, all you have to do is go to Settings-Mail, Contacts, Calendars-Gmail and then turn OFF contacts. Only the contacts from iCloud will be displayed in your contacts app. As for the birthdays, try setting the Google Calendar as your default calendar (Settings-Mail, Contacts, Calendars and then scroll down to the 'Calendars' section and select your Google calendar as the default). Hopefully, that will rectify the situation. Let us know what happens if you opt to try it out.
  9. #9  
    sting7k's Avatar
    iMore Elite

    Posts
    2,588 Posts
    Global Posts
    3,404 Global Posts
    iOS Version
    7.0.2

    Default Re: Birthday Alert Issue

    Quote Originally Posted by Wildo6882 View Post
    So I think it's something to do with the Gmail issue. For some reason it has all my gmail contact birthdays even though it doesn't have my contacts synced (all contacts are through iCloud). So they're actually listed in there twice. Guess I'll probably have to remove my contact birthdays from my gmail calendar. I think that's actually the issue.
    I've found some other comments around the web about this issue. I also have it. It seems that iOS will still show birthday notifications from a calender even if the calender is not selected. For me I traced it to my outlook.com (which I believe got birthdays from Facebook when I converted from Hotmail) calender. Even though I do not have that calender selected to display I still get notifications in notification center.
  10. Thread AuthorThread Author   #10  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Re: Birthday Alert Issue

    Quote Originally Posted by sting7k View Post
    I've found some other comments around the web about this issue. I also have it. It seems that iOS will still show birthday notifications from a calender even if the calender is not selected. For me I traced it to my outlook.com (which I believe got birthdays from Facebook when I converted from Hotmail) calender. Even though I do not have that calender selected to display I still get notifications in notification center.
    Think if I convert my Google calendar to icloud this will go away? I'm not sure how to fix it otherwise.
  11. #11  
    JustMe'D's Avatar

    Posts
    20,049 Posts
    Global Posts
    20,279 Global Posts
    iOS Version
    7.0.4

    Default Re: Birthday Alert Issue

    I'm not sure, but I would like to believe that it would.
  12. Thread AuthorThread Author   #12  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Re: Birthday Alert Issue

    So does anyone know if I just don't sync my Google calendar at all and instead move it to an icloud calendar, will this stop the double birthday notifications?
  13. #13  
    JustMe'D's Avatar

    Posts
    20,049 Posts
    Global Posts
    20,279 Global Posts
    iOS Version
    7.0.4

    Default Re: Birthday Alert Issue

    Quote Originally Posted by Wildo6882 View Post
    So does anyone know if I just don't sync my Google calendar at all and instead move it to an icloud calendar, will this stop the double birthday notifications?
    I'm not sure, but I would like to believe that it would.
    Thanked by:
    Wildo6882 (04-03-2013)
  14. Thread AuthorThread Author   #14  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Re: Birthday Alert Issue

    Quote Originally Posted by JustMe'D View Post
    I'm not sure, but I would like to believe that it would.
    Yeah, I've thought about doing that or just switching it to Outlook/Hotmail. I'll probably give it a shot. My return to the iPhone world is in the mail.
  15. Thread AuthorThread Author   #15  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Re: Birthday Alert Issue

    Anyone figured out exactly what causes this and how to stop it? I really want to continue to use Google calendar but not if this issue persists. It's a pain!
  16. #16  
    Rodville's Avatar
    iMore Intermediate

    Posts
    153 Posts
    Global Posts
    154 Global Posts

    Default Re: Birthday Alert Issue

    For me it was Facebook. It would turn the notifications back on when one of my friends had a birthday. I would turn it off and the next birthday it would be on again. And I would turn it off and it would turn itself back on the next birthday. It would even leave the notification in the notification center even after I turned it off. I just removed Facebook from syncing anything and it seems to have solved the problem.

    Q


    Sent from my Nokia 6185 using Tapatalk.
  17. Thread AuthorThread Author   #17  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Re: Birthday Alert Issue

    Well I had it synced to only my Google Calendar. No Facebook or anything else was synced. I also had birthday reminders turned off. I would still get birthday alerts in the notification center and then I would get some blaring in your face alert for someone's birthday that wasn't even listed at all. I have no clue what causes it but I hate it.
  18. #18  
    JustMe'D's Avatar

    Posts
    20,049 Posts
    Global Posts
    20,279 Global Posts
    iOS Version
    7.0.4

    Default Re: Birthday Alert Issue

    Quote Originally Posted by Wildo6882 View Post
    Well I had it synced to only my Google Calendar. No Facebook or anything else was synced. I also had birthday reminders turned off. I would still get birthday alerts in the notification center and then I would get some blaring in your face alert for someone's birthday that wasn't even listed at all. I have no clue what causes it but I hate it.
    Do me a favor please and go to your Calendar app. Afterwards, select the 'Calendars' tab in the upper left corner. Are the calendars that are listed recognizable? Do you have more than one birthday calendar listed? Is there anything listed that shouldn't be?
  19. Thread AuthorThread Author   #19  
    Wildo6882's Avatar
    iMore Pro

    Posts
    553 Posts
    Global Posts
    3,087 Global Posts

    Default Re: Birthday Alert Issue

    Quote Originally Posted by JustMe'D View Post
    Do me a favor please and go to your Calendar app. Afterwards, select the 'Calendars' tab in the upper left corner. Are the calendars that are listed recognizable? Do you have more than one birthday calendar listed? Is there anything listed that shouldn't be?
    Nothing is there out of the ordinary. I think it has more to do with a problem syncing with my Google calendar. Even though I don't have them listed, my calendar on the computer still has the birthdays in it from my contacts that are stored in Google - although I use icloud for my contacts in iOS.

Similar Threads

  1. Bluetooth alert sound issue
    By drkanter113 in forum iPhone 4S
    Replies: 4
    Last Post: 07-02-2012, 08:16 PM
  2. Google calendar sync issue - Facebook birthdays
    By dictoresno in forum iPhone 4
    Replies: 1
    Last Post: 01-04-2012, 02:26 AM
  3. calender birthdays / anniversaries alerts
    By hari.p in forum iPhone 4
    Replies: 7
    Last Post: 12-23-2009, 01:13 AM
  4. Best birthday gift
    By patcom8 in forum iPhone 4
    Replies: 10
    Last Post: 06-06-2008, 09:42 AM
  5. EDGE connectivity issues?
    By braj in forum Carrier Discussion Lounge
    Replies: 4
    Last Post: 07-05-2007, 08:57 AM

Posting Permissions