1. anygivensunday's Avatar
    I did a restore on my phone yesterday and I reloaded from a back up just because I didn't want to redownload 200+ apps but to the point. Now my email is not pushing I tried deleting the account and re adding but it still isn't pushing. I have to go into the mail and then it will load them. And the time stamp on the email is hours ago. I tried resetting network settings. Nothin is working and it seems to be coming in slow from gmail users is there anything I can try to do besides just restoring as new iPhone. ? Trying to get this fixed as soon as possible. I am missing alot of time sensitive business emails which is not good.
    Tia
    01-14-2013 11:53 AM
  2. Just_Me_D's Avatar
    Have you verified that the mail is set to push?

    Settings - Mail, Contacts, Calendars - Fetch New Data - Advanced
    01-14-2013 12:01 PM
  3. 03_CTD's Avatar
    Even restoring as new iPhone didn't work for me. I tried everything under the sun......twice. I finally gave up and set to fetch every 15 mins. Little slower and slightly worse battery life but, at least it's reliable. Sorry I don't have any help to offer. Hopefully someone will chime in here with better ideas for you. FWIW from all the research I have done on this it seems there are problems on Yahoo's end as well.
    01-14-2013 12:08 PM
  4. anygivensunday's Avatar
    Have you verified that the mail is set to push?

    Settings - Mail, Contacts, Calendars - Fetch New Data - Advanced
    Yes checked and triple checked everything before I posted. I'm all out of ideas
    01-14-2013 12:36 PM
  5. Just_Me_D's Avatar
    Yes checked and triple checked everything before I posted. I'm all out of ideas
    If your business email is via gmail, there's a slight possibility that the service disruption is experienced a few days ago has not been fully restored. Of course, I have no proof and am only guessing. I don't know what to tell you other than calling your service provider to see if there's a service disruption in your area and/or whether or not other people have complained about receiving late email messages.
    01-14-2013 12:45 PM
  6. CYaris's Avatar
    I've been having the same issue with email. I am using google apps and never had a problem before. Now, email only seems to update when I start the email program or refresh the email manually.

    All settings are correct.

    Very weird.

    Craig
    01-14-2013 04:11 PM
  7. anygivensunday's Avatar
    If your business email is via gmail, there's a slight possibility that the service disruption is experienced a few days ago has not been fully restored. Of course, I have no proof and am only guessing. I don't know what to tell you other than calling your service provider to see if there's a service disruption in your area and/or whether or not other people have complained about receiving late email messages.
    I don't use gmail mine is yahoo I'm mostly experiencing the slowness when the sender is gmail user
    01-14-2013 06:03 PM
  8. Just_Me_D's Avatar
    I don't use gmail mine is yahoo I'm mostly experiencing the slowness when the sender is gmail user
    That is weird. According to DownRightNow, both services had disruptions 4 days ago. Maybe there are still unresolved issues.
    Last edited by JustMe'D; 01-14-2013 at 09:29 PM.
    01-14-2013 06:13 PM
  9. anygivensunday's Avatar
    That is weird. According to DownRightNow, both services had disruptions 4 days ago. Maybe there are still unresolved issues.
    Oh ok I did not know that. Thank you all for trying to help.
    01-14-2013 07:38 PM
  10. Slammers08's Avatar
    Oh ok I did not know that. Thank you all for trying to help.
    I had the same exact issue when I had to replace my iphone 5 with gmail email. For whatever reason it takes awhile(days) to get the email to push. It will work it takes time. Why I can't figure it out. But it will work.
    01-14-2013 08:33 PM
  11. Massie's Avatar
    I'm surprised no one has mentioned the fact that Google dropped support for new Exchange accounts on the iPhone...when the news broke, this was a big question: how would a restore be treated by Google, as a new setup (which wouldn't get Exchange/push support) or as an existing one (which would)? Could this be a sign?

    (Edit: looks like it still supports new accounts until January 30 2013 so that's probably not it.)
    01-15-2013 12:19 AM
  12. CYaris's Avatar
    My phone wasn't restored as new, but it still has the issues.

    It is set up as an exchange, but I don't believe that is the problem.

    Then again, what do I know?
    01-16-2013 10:43 AM
  13. Just_Me_D's Avatar
    I'm surprised no one has mentioned the fact that Google dropped support for new Exchange accounts on the iPhone...when the news broke, this was a big question: how would a restore be treated by Google, as a new setup (which wouldn't get Exchange/push support) or as an existing one (which would)? Could this be a sign?

    (Edit: looks like it still supports new accounts until January 30 2013 so that's probably not it.)
    I'm still getting my gmail pushed to me via the exchange method and I haven't noticed any disruptions as of late either.
    01-16-2013 11:30 AM
  14. Just_Me_D's Avatar
    My phone wasn't restored as new, but it still has the issues.

    It is set up as an exchange, but I don't believe that is the problem.

    Then again, what do I know?
    I sent myself 2 test messages from my iCloud account to my gmail account. The first message was sent while connected to Wi-Fi and the second was sent via 3G. Both messages were received almost instantly after sending them. Of course, this test was done via my 4S running iOS 6.0.1 because I do not have the iPhone 5.
    01-16-2013 11:35 AM
  15. John Yester's Avatar
    I sent myself 2 test messages from my iCloud account to my gmail account. The first message was sent while connected to Wi-Fi and the second was sent via 3G. Both messages were received almost instantly after sending them. Of course, this test was done via my 4S running iOS 6.0.1 because I do not have the iPhone 5.
    I tested using 4 Gmail address services and one iCloud and one on Exchange server

    All pushed at same time.


    Don't use Gmail personal. these are through my Google domain.
    01-16-2013 12:56 PM
  16. 03_CTD's Avatar
    I tested using 4 Gmail address services and one iCloud and one on Exchange server

    All pushed at same time.


    Don't use Gmail personal. these are through my Google domain.
    I set my gmail up as exchange last night. Gmail and iCloud push at the same time. Yahoo won't push at all. iPhone 5 on 6.0.1.
    01-16-2013 05:19 PM
  17. anygivensunday's Avatar
    I sent myself 2 test messages from my iCloud account to my gmail account. The first message was sent while connected to Wi-Fi and the second was sent via 3G. Both messages were received almost instantly after sending them. Of course, this test was done via my 4S running iOS 6.0.1 because I do not have the iPhone 5.
    Yea email on my 4s is fine too it's just the 5
    01-16-2013 10:10 PM
  18. ryanlawrence171's Avatar
    Just reset your iPhone, it will works good after that...
    01-18-2013 12:33 AM
  19. CYaris's Avatar
    Ok, seems a reset did the trick. Thanks for pointing out what should have been obvious to me. It is much appreciated, ryanlawrence171!

    Craig
    01-18-2013 11:57 AM

Similar Threads

  1. Wifi issues on my 3G
    By 132_and_bush in forum iPhone 4
    Replies: 0
    Last Post: 11-12-2010, 07:36 PM
  2. can I have my gmail and att.net emails both push on my ip4?
    By motox151 in forum Google and Gmail
    Replies: 5
    Last Post: 08-02-2010, 03:51 AM
  3. Replies: 3
    Last Post: 04-12-2010, 10:54 AM
  4. email crashes on my iphone 3gs
    By saran_arts in forum iPhone 3GS Forum
    Replies: 4
    Last Post: 12-17-2009, 08:41 PM
  5. Email on my IPHONE
    By bigmeetsv69 in forum iPhone 4
    Replies: 3
    Last Post: 11-17-2008, 01:19 AM
LINK TO POST COPIED TO CLIPBOARD