1. gregs1213's Avatar
    Whenever I'm out and about, I noticed my iphone will connect to unsecured wi-fi networks automatically without asking my to join the network. I have the option ON to ask to join any network before I connect, but it doesn't do it. I tried searching for an answer, but all i am finding is that many people are having the opposite problem connecting to an unsecured network. Any advice would be greatly appreciated.

    11-25-2012 05:38 PM
  2. robertk328's Avatar
    If its names the same as another network you have joined (like the generic "linksys") this will happen. You need to click the arrow next to the network name when connected
    and choose "forget this network".

    Does that help or is this a case where it is joining networks with names you have never joined before? Even then you should try the tip above and see if it helps.
    11-25-2012 05:41 PM
  3. Peligro911's Avatar
    Reset network settings So it forgets the network and turn off the notify me of new networks


    Sent from my iPhone 5 from a galaxy far far away (in the USA ) using Tapatalk !
    11-25-2012 05:42 PM
  4. gregs1213's Avatar
    If its names the same as another network you have joined (like the generic "linksys") this will happen. You need to click the arrow next to the network name when connected
    and choose "forget this network".

    Does that help or is this a case where it is joining networks with names you have never joined before? Even then you should try the tip above and see if it helps.
    Thanks, but it continues to join networks with names that I've never joined before. For instance, if I am at Starbucks, it will automatically connect me to the Wi-Fi even if I've never connected before .. It connects to all sorts of weird unsecured networks as well..
    11-25-2012 05:48 PM
  5. robertk328's Avatar
    Reset network settings So it forgets the network and turn off the notify me of new networks


    Sent from my iPhone 5 from a galaxy far far away (in the USA ) using Tapatalk !
    Be careful - this will forget your stored network passwords.
    11-25-2012 05:49 PM
  6. robertk328's Avatar
    Thanks, but it continues to join networks with names that I've never joined before. For instance, if I am at Starbucks, it will automatically connect me to the Wi-Fi even if I've never connected before .. It connects to all sorts of weird unsecured networks as well..
    Are you on AT&T? I think that's who Sbux uses which may be why.
    11-25-2012 05:49 PM
  7. gregs1213's Avatar
    Yes, I'm on ATT.. but it's not only starbucks, for instance when I'm near my boyfriends house it will connect me to "Time Warner - Unsecured".. or at "McDonalds - Unsecured" or when I'm just driving by a random place.. These are places I've definitely never connected to before.
    11-25-2012 05:53 PM
  8. Fausty82's Avatar
    Yes, I'm on ATT.. but it's not only starbucks, for instance when I'm near my boyfriends house it will connect me to "Time Warner - Unsecured".. or at "McDonalds - Unsecured" or when I'm just driving by a random place.. These are places I've definitely never connected to before.
    I don’t know about "Time Warner - Unsecured", but if you are on AT&T, you will automatically connect to any AT&T HotSpot wifi locations...
    11-25-2012 06:07 PM
  9. kilcher's Avatar
    McDonalds uses AT&T wifi. Not sure if that's it.


    Follow me on the Twitter! @_jorts
    11-25-2012 06:10 PM
  10. anygivensunday's Avatar
    Why not just turn wifi off when u leave the house. Therefore it won't search for networks while your out and it won't connect to any network because its not looking for one to connect to ???


    Sent from my iPhone 4S using Tapatalk
    11-25-2012 06:35 PM
  11. jbs-horn's Avatar
    There's a setting under "Settings/Wi-Fi" called "Ask to Join Networks." Turn this off and it will stop trying to connect you to new networks.
    11-25-2012 07:22 PM
  12. robertk328's Avatar
    There's a setting under "Settings/Wi-Fi" called "Ask to Join Networks." Turn this off and it will stop trying to connect you to new networks.
    That's just it. The phone is connecting without being asked, which is what that setting is for.

    My thoughts are the ones the OP is connecting to are the AT&T free wifi that you get free access to. Not sure I'd like it automatically connecting though. I don't always trust those.
    11-25-2012 08:18 PM
  13. jbs-horn's Avatar
    On my phone, turning off the "ask" setting results in the wifi not attempting to connect unless I search for a connection. In McDonalds, Sam's, and a number of other places it just stays on "4G".
    11-25-2012 08:51 PM
  14. robertk328's Avatar
    On my phone, turning off the "ask" setting results in the wifi not attempting to connect unless I search for a connection. In McDonalds, Sam's, and a number of other places it just stays on "4G".
    Do you have to have it search on your home wifi each time or does it automatically connect? I have mine set this way and it still connects to known networks.
    11-25-2012 08:56 PM
  15. jerome g's Avatar
    Why does it matter ?
    It does not drain much of the battery.
    Most folks have wifi on all of the time like myself.
    I get great battery life.
    11-25-2012 09:36 PM
  16. Peligro911's Avatar
    Like I said resetting network settings should fix it .. You will have to type your wifi password for your home as it Won't remember any wifi anymore until u connect for the first time


    Sent from my iPhone 5 from a galaxy far far away (in the USA ) using Tapatalk !
    11-25-2012 10:27 PM
  17. John Yester's Avatar
    Agreed, resetting network settings should fix things up...


    I have never had my device connect to any network unless stored. It should always ask.
    11-25-2012 10:47 PM
  18. SeanHRCC's Avatar
    If resetting the network settings does not fix this...you're either A.) Connecting to networks with mirrored names (which happens often because many people don't name their networks, especially if they have multiple networks), or B.) You have a faulty device.

    Reset the network settings...if it's still a problem, take the phone back and get a new one.
    11-26-2012 08:22 AM

Similar Threads

  1. Iphone 4 with iOS 5 killing home wi-fi network
    By tony-22 in forum iPhone 4
    Replies: 0
    Last Post: 10-17-2011, 03:54 PM
  2. Can't connect to home Wi fi
    By seyheykid in forum iPhone 4
    Replies: 11
    Last Post: 10-16-2010, 12:05 PM
  3. Replies: 4
    Last Post: 07-17-2009, 07:56 AM
  4. Connect to secure WI FI
    By Sigurdhoy in forum iPhone 4
    Replies: 2
    Last Post: 11-25-2008, 02:19 PM
  5. How to Trick Your iPhone Into Thinking Its On Wi-Fi
    By jamesus in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 0
    Last Post: 11-06-2008, 02:54 PM
LINK TO POST COPIED TO CLIPBOARD