1. Barratrous Brighton's Avatar
    Hi, I am having trouble activating Imessage on iPhone 5 IOS6. It is constantly saying waiting for activation. I have ensured that my apple ID and password are correct. I have switched iMessage on and off several times, as well as my phone and all of my other devices are coming up with my iphone is now using my email address. I also ensure that I am connected to WIFI.
    Has anyone had this issue and can help me fix mine.
    11-12-2012 06:50 AM
  2. GingerSnapsBack's Avatar
    Turn your phone off and then back on. I've had to do that a few times to get iMessage to act right.
    11-12-2012 08:07 AM
  3. johnanondoe's Avatar
    I had a similar issue are tried everything I could find online to fix it. At the end, I realized that my carrier had put a block on "spam" text messages. When you turn iMessages on it basically sends an invisible text message to Apple to verify it. With the block, the text message wasn't sent.

    That probably just confused you more than helping you. Just call your carrier and ask them if there is some kind of spam SMS block. If there is, have them remove it and you'll be good.
    11-12-2012 09:33 AM
  4. winniesi's Avatar
    agree to johnanondoe, its annoying
    12-08-2012 07:21 AM
  5. eb_therebel's Avatar
    Hi, I am having trouble activating Imessage on iPhone 5 IOS6. It is constantly saying waiting for activation. I have ensured that my apple ID and password are correct. I have switched iMessage on and off several times, as well as my phone and all of my other devices are coming up with my iphone is now using my email address. I also ensure that I am connected to WIFI.
    Has anyone had this issue and can help me fix mine.
    Try toggling airplane mode on for 5 seconds and turning it back off. This happened to me when I first got my i5 but that fixed it for me
    ChrisLuce#IM likes this.
    12-11-2012 05:51 AM
  6. Yptcn's Avatar
    This might help.

    Make sure that Time & Date ( In Settings-General ) are on automatic.

    In Settings-Privacy-Locations-System Service ( All the way down ),make sure Define Time Zone is on.

    It worked for me after pulling out a lot of hair ;-)))
    12-11-2012 11:00 AM
  7. timbervision's Avatar
    The tip given above worked immediately after so much frustration. Simply go to Settings, then General, then Date and Time, and then select "Set Automatically."
    12-28-2015 06:55 PM
  8. Just_Me_D's Avatar
    The tip given above worked immediately after so much frustration. Simply go to Settings, then General, then Date and Time, and then select "Set Automatically."
    FYI: Did you notice the date of the post above yours?
    12-28-2015 07:00 PM

Similar Threads

  1. imessage activation
    By Maha4 in forum iPhone 4S
    Replies: 1
    Last Post: 05-05-2012, 05:23 PM
  2. 4s SIM activation issues
    By Oliverg109 in forum iPhone 4S
    Replies: 2
    Last Post: 11-06-2011, 06:26 PM
  3. Activation issues? (Any carrier)
    By MarcGoldie in forum iPhone 4S
    Replies: 50
    Last Post: 10-14-2011, 11:28 PM
  4. Replies: 24
    Last Post: 02-11-2011, 11:17 AM
  5. activation issue after upgrade, 'NO SERVICE'.
    By Tana in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 07-07-2009, 06:59 AM
LINK TO POST COPIED TO CLIPBOARD