Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By kch50428
  1. Thread AuthorThread Author   #1  
    ajsberrybold's Avatar
    iMore Newbie

    Posts
    33 Posts
    Global Posts
    58 Global Posts

    Default Do we need this update...?

    Just wondering if this 6.0.1 update for us 4s users is even necessary? Thanks in advance!
  2. #2  
    kch50428's Avatar

    Posts
    10,556 Posts
    Global Posts
    11,437 Global Posts
    iOS Version
    7.0

    Default Re: Do we need this update...?

    Quote Originally Posted by AJSaNewb View Post
    Just wondering if this 6.0.1 update for us 4s users is even necessary? Thanks in advance!
    Necessary? Maybe - maybe not - however, there are things in the update for every device that is capable of running iOS6 - addressing security issues and various bug fixes that are not individually identified.

    Just do it.
    Keith - iMore Moderator - The Mobile Nations/iMore Forum Rules
     iPhone5 on VZW;  iPad(2012) - wifi with BadElf for GPS
    "When the debate is lost, slander becomes the tool of the loser." -- Socrates
    Thanked by:
    ajsberrybold (11-02-2012)
  3. #3  
    JustMe'D's Avatar

    Posts
    19,198 Posts
    Global Posts
    19,427 Global Posts
    iOS Version
    7.0.4

    Default Do we need this update...?

    Is it "necessary"? I doubt it. There are still 4S users running iOS 5, 5.0.1 & 5.1.1 and are quite satisfied. I do, however, agree with Keith that updating to the latest version is recommended.
    Thanked by:
    ajsberrybold (11-02-2012)
  4. #4  
    RWWackostu's Avatar
    iMore Intermediate

    Posts
    105 Posts
    Global Posts
    2,182 Global Posts
    iOS Version
    iOS 6.0.1

    Default Re: Do we need this update...?

    As I always said over on the CB Forums - There is a reason for the updates. There might also be something "under the hood" that may make your device run a little better. Bug fixes, OS tweaks and the like are desirable. I wold think that would be considered "necessary"
    Overcame my Crackberry addiction by realizing that my device just had to work. If iPhone/iPad owners are sheep, then I just joined the flock.

    iPhone 4S, iPad 3 32G

    @wackostu on Twitter
    Thanked by:
    ajsberrybold (11-02-2012)
  5. Thread AuthorThread Author   #5  
    ajsberrybold's Avatar
    iMore Newbie

    Posts
    33 Posts
    Global Posts
    58 Global Posts

    Default Re: Do we need this update...?

    Great Thanks!
  6. #6  
    kch50428's Avatar

    Posts
    10,556 Posts
    Global Posts
    11,437 Global Posts
    iOS Version
    7.0

    Default Re: Do we need this update...?

    Revised to note: Linked Article no longer exists at source....


    If anyone is wondering if this update is worthwhile for anyone with something other than an iPhone5... look here:



    So...even though the hype around an iOS update may not specify anything for your specific device... there may be something in it for you - so just update.
    Keith - iMore Moderator - The Mobile Nations/iMore Forum Rules
     iPhone5 on VZW;  iPad(2012) - wifi with BadElf for GPS
    "When the debate is lost, slander becomes the tool of the loser." -- Socrates
    RWWackostu likes this.
  7. #7  
    Jaguarr40's Avatar
    iMore Genius

    Posts
    12,919 Posts
    Global Posts
    17,061 Global Posts
    iOS Version
    iOS 7.1.2

    Default Re: Do we need this update...?

    Well I agree with Keith also as well as JMD and one last thing, If they did not have it as much complaining as most everyone did about ALL the bugs everyone found by updating if Apple did not come out with a bug fix ALL of you would be blasting Apple for not doing anything. Now the OP wants to know if it was needed.

    To the OP what do you think?
    ~JAG~
    Member Of iMore & Mobile Nations!
    In Memory Of Steve Jobs ... Rest In iPeace


  8. #8  
    Roo Zilla's Avatar
    iPhone Intermediate

    Posts
    228 Posts
    Global Posts
    2,567 Global Posts

    Default Re: Do we need this update...?

    If you're security conscious..... here's a link to the security holes patched in this update:

    There are some people who for some strange reason, that if they're on a diet, they don't want you to eat a cupcake. If you do eat a cupcake, all they want to do is tell you that it tastes bad.
  9. #9  
    jbs-horn's Avatar
    iMore Nanite

    Posts
    5 Posts
    Global Posts
    172 Global Posts
    iOS Version
    5.1.1

    Default Do we need this update...?

    For those of us who work with Exchange calendars or with Google calendars over Exchange ActiveSync, the upgrade fixed a show-stopping bug in 6.0 that prevented meeting invitations from being transmitted.

Similar Threads

  1. Replies: 7
    Last Post: 04-29-2013, 06:17 PM
  2. Do I need to update to 4.2.10 before going to iOS 5 on my JB iPhone 4?
    By HPepper in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 3
    Last Post: 10-11-2011, 07:37 PM
  3. Do I need to update?
    By JonMark in forum OS X
    Replies: 4
    Last Post: 07-22-2011, 12:37 PM
  4. Replies: 12
    Last Post: 09-08-2010, 09:46 PM
  5. do I need to update cydia?
    By leica1215 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 4
    Last Post: 08-02-2009, 08:20 PM

Posting Permissions