1. crazysarah's Avatar
    Hi all. I've just finished coding up my first proper website and having tested it on all the browsers you can install on a windows PC I was hoping that things would go painlessly. Not so...

    When I borrowed my friends ipad and looked the page took an absolute age to load. And sometimes it wouldn't load at all. After checking other websites etc I'm sure it's not the connection. I have some Javascript I had never used before, could this be causing the problem? Sometimes it looks like it's taking a long time loading the FB, google and twitter buttons. Do they cause problems on iphones and ipads?

    Unfortunately my problem is made worse because I can't easily get my hands on an ianything as I don't own one myself and all the emulators/simulators I've found don't appear to be 100% authentic. So it'd even be useful if someone could tell me if they have problems too.

    Can anyone help me out?
    the site's at www.traditionalirishgifts.com

    I'd appreciate it
    11-22-2012 12:28 PM
  2. warcraftWidow's Avatar
    The page loads acceptably in my iPhone 5. I only went to the home page.
    11-22-2012 03:24 PM
  3. crazysarah's Avatar
    Well thats good to hear, thanks for that. Strange though. The ipad I checked it on was brand new.

    Anyone else have no issues?
    11-22-2012 04:11 PM
  4. SweetSCBerry's Avatar
    It works for me with no issues.


    Sent from my iP5 using Tapatalk
    11-22-2012 05:42 PM
  5. crazysarah's Avatar
    Hummm... I wonder if my friends ipad is broken then... It's pretty new (like a couple of months old) but pages just wouldn't load properly. Not only the really long loading times but also some css issues (horizontal nav bar goes onto two lines so there is a 'price range' link hovering just below the horizontal nav bar.

    Any body got an older pad or phone? looks like only 5s so far

    thanks by the way, I really appreciate this and really want to get this sorted.
    11-22-2012 06:45 PM
  6. warcraftWidow's Avatar
    I'll try again when I get home on my iPad. At thanksgiving with the in-laws right now.
    11-22-2012 08:02 PM
  7. warcraftWidow's Avatar
    I just tried it on my iPad. Everything appears to be working except the drop down menus. I clicked around, added something to the shopping cart, deleted it from the cart, used the left side menus where they were available, clicked some of the links at the bottom, etc. but even zoomed in I couldn't get the drop down menus to work.
    11-22-2012 09:37 PM
  8. crazysarah's Avatar
    Bugga... Ok, I'll have to go and figure all this out then. Thank you very much for taking the time to look for me.
    11-23-2012 08:33 AM
  9. warcraftWidow's Avatar
    I took a quick look at the page source, javascript, and css and without digging into it too much, I'd guess that your problem is because you've only defined hovers for the dropdown menus. And obviously hovers don't work for touch screen devices. Maybe they should also show up "onClick"? It looks like you are using jQuery (although I'm not sure if you were using it for the dropdown menus). There is also a jQuery Mobile set of javascript which may help.

    BTW...if this is your time designing and creating a website, it's pretty impressive.
    11-23-2012 03:31 PM
  10. crazysarah's Avatar
    Hi Karen, thanks, can't take credit for the design, got a designer to do that for me. It's my first proper website, rather than just using a slightly modified opensource cart with a template. I've done a bit of custom coding and using javascript for the first time and learned a bunch on the way. So first proper website.

    Re the hover thing. I've checked and they work on my touch screen android when I touch them. To be fair that menu is based on a plugin and off the top of my head I can't remember how its put together. I'll have to go and figure it out

    Thanks for the info. Very kind.
    11-23-2012 04:41 PM

Similar Threads

  1. Replies: 30
    Last Post: 09-11-2012, 04:03 AM
  2. Wi-Fi problems with the new iPad
    By Rene Ritchie in forum iPad 3
    Replies: 36
    Last Post: 05-10-2012, 11:07 AM
  3. The real problem with the new iPad
    By arcadelion in forum iPad 3
    Replies: 16
    Last Post: 03-29-2012, 09:35 AM
  4. Problems with the cameras on my iPhone 4
    By Sergeant_Manny in forum iPhone 4
    Replies: 9
    Last Post: 01-30-2012, 08:33 PM
  5. Replies: 8
    Last Post: 04-13-2011, 03:21 PM
LINK TO POST COPIED TO CLIPBOARD