Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    stroghty's Avatar
    iPhone Nanite

    1 Posts

    Default Please Help 3g issue

    This my first time to jailbreak and all went well. I first used jailbreakme but kept having issue so did hard reset then used redsnow and works great.

    The issue is my 3g toggle option in settings has changed to "Cellular Data" on/off.. After installing SBsettings the toggle for 3g will not stay on. It does say 3g on my status bar


    After I first jailbroke the toggle in sbsettings for 3g woirked perfectly but after a bit (not sure if after something else installed) it wouldnt stay on. Every time I open the sbsettings the 3g toggle is red, I click it and it becomes green then close screen to reopen to red toggle.. I also installed voiceactivator and set it up to toggle 3g on and off but everytime I toggle it it say 3g enabled like it was stays off...

    I have done several comeplete resets to try to fix and after the reset (complete reset to factory) the 3g option in the settings still is missing..

    Is there anyting I can try to correct this?
  2. #2  
    kch50428's Avatar
    iMore Genius

    20,835 Posts
    Global Posts
    21,716 Global Posts


    I think you're seeing an issue with SBSettings on Verizon iPhones. I've found that the control in SBSettings for the 3G on my phone to be irrelevant - the only place I can turn data on or off is in the native Settings app.
  3. #3  
    ProEvo's Avatar
    iPhone Beginner

    50 Posts
    Global Posts
    55 Global Posts


    Are you connected to wifi? My 3G icon turns off when I am. It should still state 3G in the status bar when you aren't on wifi. Oh and since your at it, google 3G Booster.

Posting Permissions