Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread AuthorThread Author   #1  
    jonmark's Avatar
    iMore Intermediate

    274 Posts
    Global Posts
    403 Global Posts

    Default Has this music sync problem happened to you?

    So I downloaded about 15 new songs today and plugged in my iPhone 4 to iTunes to sync them on to it. After it finished syncing I unplugged my iPhone and went to the iPod app "just to check" .. and when I did it said, "Updating Library This May Take a Few Minutes" .. Weird, but alright left it alone. A few minutes later I opened the iPod app again and all my music was gone. There were no playlists, no songs, nothing. I panicked, respringed, and still nothing. Plugged it back into iTunes and sure enough it shows all my music folders still "checked" to sync, and even the memory bar at the bottom shows over 9GB of music .. So I just hit the sync button again for the heck of it .. It went through the steps in about 20 seconds, unplugged, and all my music was back.

    So weird ... has this happened to anyone else?
  2. #2  
    BreakingKayfabe's Avatar
    iMore Genius

    6,429 Posts
    Global Posts
    6,810 Global Posts


    Yupppp. That happened to me when I got an itunes error message once. I can't
    remember exactly what the message was but I googled it and sure enough I had
    to restore my iPhone all together. Once I did it, the error message problem was
    resolved. But when iTunes supposedly synced, my library on the iPod app was
    empty. I had to connect again and sync in order for the songs to show up again.
  3. #3  
    mrsFAB's Avatar
    iPhone Beginner

    61 Posts
    Global Posts
    829 Global Posts


    Happened to me back when iOS 4.2 came out. Synced it again and all was well again...
  4. #4  
    impaler's Avatar
    iMore Pro

    623 Posts
    Global Posts
    684 Global Posts


    I'm with MrsFAB, it happened to me too when I upgraded to iOS 4.2 on my 3GS. I just plugged it back into iTunes, did another sync and all was good.

Posting Permissions