Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread AuthorThread Author   #1  
    travk1234's Avatar
    iPhone Nanite

    Posts
    3 Posts

    Default having to reset iPhone4 daily to use 3g

    What would be causing my 3G to quit?

    My phone will show full coverage and 3G but wont connect to anything requiring it. Voice will work fine but data wont work
    Rebooting will fix the problem until the next day and I will have to reboot again.

    Is their a way to fix this without restoring it?
  2. #2  
    Yommer84's Avatar
    iPhone Newbie

    Posts
    18 Posts

    Default

    Is the cellular setting turned to on in the settings and network area?
  3. Thread AuthorThread Author   #3  
    travk1234's Avatar
    iPhone Nanite

    Posts
    3 Posts

    Default

    Yes it is.
  4. #4  
    markhunsaker's Avatar
    iMore Intermediate

    Posts
    483 Posts
    Global Posts
    3,143 Global Posts

    Default

    That sounds like you might try a hard reset by restoring your phone via iTunes. Than if that fails, exchange your phone.
  5. #5  
    P@t
    P@t is offline
    P@t's Avatar
    iMore Newbie

    Posts
    38 Posts

    Default

    Have you done the carrier update for VZW?




    Sent from my iPhone using Tapatalk
  6. Thread AuthorThread Author   #6  
    travk1234's Avatar
    iPhone Nanite

    Posts
    3 Posts

    Default

    I'm on Verizon 10.1
    I haven't been able to restore yet.
  7. #7  
    d0ster's Avatar
    iPhone Beginner

    Posts
    54 Posts

    Default

    A quicker way maybe to turn Airplane mode on for about 10 seconds then back off. You'll see it say searching and then after the bars show up, 3G shows up right after. It's quicker than a reboot and works for me I have this issue also from time to time but not daily like you.
  8. #8  
    silliybilly's Avatar
    iPhone Nanite

    Posts
    7 Posts
    Global Posts
    50 Global Posts

    Default

    The warehouse I work in has a few low signal areas and it seems if I spend a few hours in these areas, I lose the ability to use data even though "3G" is showing on the status bar. It doesn't happen all the time but like the above poster stated, all I have to do is switch into "Airplane" mode for a few secs and everything will work again. I'm wondering if there is some kinda power save mode built into the software that turns off data when signal is low for a longer period of time.

Posting Permissions