1. dndrich's Avatar
    Tipb Pals:

    Loving my new iPhone 4. I have set up Gmail with exchange, and that is working perfectly. Also, my calendar is working perfectly with push both directions. Changes made on the phone show up on google immediately, and the other direction works similarly. Now, when I set up the phone, my contacts all came down no problem. But, when I make a new contact on the phone, it doesn't show up in Google contacts, just on the phone. But if I make the contact on the Google side in "my contacts", it shows up immediately on the phone. There is some issue with "my contacts", and "all contacts" that I just don't quite understand. So, any ideas about how to get that to work correctly?
    02-09-2011 08:36 PM
  2. dndrich's Avatar
    Tipb Pals:

    Loving my new iPhone 4. I have set up Gmail with exchange, and that is working perfectly. Also, my calendar is working perfectly with push both directions. Changes made on the phone show up on google immediately, and the other direction works similarly. Now, when I set up the phone, my contacts all came down no problem. But, when I make a new contact on the phone, it doesn't show up in Google contacts, just on the phone. But if I make the contact on the Google side in "my contacts", it shows up immediately on the phone. There is some issue with "my contacts", and "all contacts" that I just don't quite understand. So, any ideas about how to get that to work correctly?
    Ooh! I think I figured out my own question. Under Settings, Contacts, on the phone, the default was set to on my iphone. I changed it to default to exchange, and it now works both directions!
    02-09-2011 08:45 PM
  3. shinbone's Avatar
    I'm interested in the difference in behavior in the 2 settings:
    Default account >"on my phone" vs "exchange"

    Why is the default setting "on my phone" if (as dndrich has pointed out), "exchange" option seems to work better? Should I change to "exchange" as well? I'm also using gmail set up via exchange.
    02-09-2011 10:38 PM
  4. takeshi's Avatar
    Depends on what you want to use the default account for contacts. Contacts on your phone won't sync with your Exchange (gmail, in this case) account.
    02-09-2011 10:45 PM
  5. dndrich's Avatar
    Yes, I agree. If you want all your contacts synced to google like I do so they are saved, then change that setting to exchange. That way contacts can be saved and shared among all your devices.
    shinbone likes this.
    02-09-2011 10:51 PM
LINK TO POST COPIED TO CLIPBOARD