Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. Thread AuthorThread Author   #1  
    doncomp's Avatar
    iPhone Nanite

    Posts
    4 Posts
    Global Posts
    9 Global Posts

    Default Unresponsive areas of touch screen.

    Seems I've had a run of three Dig/LCD assemblys with touch problems --
    One has the third vertical column of non-reactive icons.
    One has the bottom row ...etc
    One has the problem on the bottom row, third icon area, really shows up when can't type certain letters in msgs.

    My main question: Since it doesn't appear to be a software problem (many restores, reboots, DFU; and, trying other assemblys -- Is this a Digitizer or LCD problem?

    "Take it to an Apple store" is not an option.
  2. #2  
    Cleveland's Avatar
    iMore Specialist

    Posts
    1,465 Posts
    Global Posts
    2,091 Global Posts

    Default

    yes it would be safe to assume it's a digitizer or LCD issue, and since Apple store isn't an issue, unfortunately you're either stuck with it like that or you'd have to replace the digitizer/LCD yourself or find a place that will do it ..
  3. Thread AuthorThread Author   #3  
    doncomp's Avatar
    iPhone Nanite

    Posts
    4 Posts
    Global Posts
    9 Global Posts

    Default

    That's a fair summation of my question -- Is it a Dig or an LCD issue??
    Your suggestion is to find someone to replace the whole assembly...
  4. #4  
    SeanHRCC's Avatar
    Banned

    Posts
    12,210 Posts
    Global Posts
    12,215 Global Posts

    Default

    Does the phone have water damage? (indicators triggered?)
  5. Thread AuthorThread Author   #5  
    doncomp's Avatar
    iPhone Nanite

    Posts
    4 Posts
    Global Posts
    9 Global Posts

    Default

    I get the same result on different 'good' boards. I just this morning replaced the digitizer glass on one assembly and it fixed the problem. So, I suppose I've answered my own question.
  6. #6  
    OmariJames's Avatar
    iPhone Intermediate

    Posts
    472 Posts

    Default

    This has happened to me on the 3G , I got the display replaced then I got the phone replaced afterwards because the problem came back.

    Now on the 3GS , its been happening again and for me taking it for to the store is not an option for me either.

    I'm just going to up with it until the 5 or what ever it is comes out
  7. #7  
    Cleveland's Avatar
    iMore Specialist

    Posts
    1,465 Posts
    Global Posts
    2,091 Global Posts

    Default

    Quote Originally Posted by doncomp View Post
    I get the same result on different 'good' boards. I just this morning replaced the digitizer glass on one assembly and it fixed the problem. So, I suppose I've answered my own question.
    Lol glad to see that was the issue and now something that couldn't be figured out

Tags for this Thread

Posting Permissions