1. kingweb's Avatar
    I have set in the email settings to show 200 most recent messages. In my real inbox (the one in my outlook on my pc), there is a total of about 50-60 messages dating back for about 1 month.
    However, both my ipad and iphone4 only show me messages from the past 3 or 4 days, and far less than 200 messages.

    1. How do I get my 200 most recent messages to show in my inbox on my ios devices?

    2. Is there some jailbreak app maybe that will give me better control over the email settings?

    I am using Microsoft Exchange.
    10-16-2010 10:37 PM
  2. MachoDonut's Avatar
    Go to Settings > Mail, Contacts, Calendars > <Exchange Account in question>. Check your setting for "Mail Days to Sync". It's probably set to 3 days.
    kingweb likes this.
    10-16-2010 11:52 PM
  3. kingweb's Avatar
    Yes, that was it. Thanks!
    10-17-2010 12:47 AM
  4. Jellotime91's Avatar
    I have the same problem, I changed mine to "No Limit" and it still is only showing 3 email messages...
    10-17-2010 02:37 AM
  5. sigmamason's Avatar
    I have the same problem, I changed mine to "No Limit" and it still is only showing 3 email messages...
    Have you deleted your account and reinstalled it? Had to do that with every phone on Exchange...it will be ok after that...
    10-17-2010 10:42 AM
  6. Roo Zilla's Avatar
    Just FYI, but you can also sync multiple Exchange folders. For example, if you frequently need access to your sent items, you can sync the "Sent" folder so you will always have quick access to it instead of waiting for it to download.
    10-17-2010 12:52 PM
LINK TO POST COPIED TO CLIPBOARD