Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread AuthorThread Author   #1  
    Listy's Avatar
    iPhone Intermediate

    144 Posts

    Default iPhone drivers corrupt.

    Ok this started with two problem which now I have had the phone open and another closer inspection the other problem was a lose connection also. The first needed a touch of Supa Glue very neatly placed and the second problem fixed has corrupted the iPhone drivers and it won't stay connect. Disconnects straight after you connect. So I plugged it into the Pc next to it and there is no problems. I have to put the phone back together now but it not taking the drivers off THIS phone. I have another iPhone here I could use the drivers of that, or update now i have charge now, I could..;(( system restore. Just need fresh iPhone drivers. Uninstall and reinstall from where.

    These were my first issues
    I have two issues rendering my phone useless. The microphone is not working and after a bit of research and testing I found the problem to be the switch inside the 3.5 headphone jack. It can get stuck and the suggestion is to plug in the headphones in and try and release the switch. It didnít work but if I fiddle with it I can hear the microphone coming in and out. So I know the problem but donít have a fix.

    At the same time (same day) the data and charge connection became unstable and now I cant get a connection at all, even when I move the connection about. I have opened the phone and besides a lot of dust everything seemed ok. When I plug in an external battery I do get a light register on the battery and the 'you need to plug in to power' picture show on the screen but it doesn't take power nor register the connection in iTunes.

    I'm at my wits end with it. If I send it back to Apple it going to take up to four weeks with the Christmas break and there is a chance they will give me a 3Gs which I don't want due to the tethered issue after jailbreaking and then not being able to turn the phone off without having to run Blackrain to get it started again.

    I did a back-up recently, but would love to get enough charge in the phone to get a few pics out. Any help would be appreciated.
    Last edited by Listy; 12-19-2009 at 02:53 PM.

Posting Permissions