Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread AuthorThread Author   #1  
    jetv1r's Avatar
    iPhone Nanite

    1 Posts

    Default Not finding wifi

    i have new 3gs ver.3.1.2 JB my problem is, its not registering any wifi connection on my fon, even if i put in the network name and security details, it doesn't recognize my wifi, there is a lot of wifi in our area that is being able to see by my laptop but my iphone doesn't. Need some help pls.
  2. #2  
    flyingember's Avatar
    iPhone Elite

    1,986 Posts
    Global Posts
    2,026 Global Posts


    does the phone see the wifi connection at all?

    what are the security settings on the wifi? (don't need key, just the type setup)

    what is the model of the router? are you using b/g/n or a? if the former, is the router in mixed mode or set to only allow certain conenctions (i.e. via "n")?
  3. #3  
    dcallagh's Avatar
    iPhone Nanite

    1 Posts



    No help for you I'm afraid, but I have the same issue.
    Loss of WiFi, from reading around (yes, I'm a forum ho') seems to be related to loss of the wireless address....
    Mine was on the blink in any case(sometimes on, sometimes off), and I had reset the network settings.
    I updated to 3.1.2 and wifi is no longer an Iphone option!!
    Phone can't find the network supplier either half the time and has to be rebooted. Its not a phone - its a PC (yes, like 'PC' in the ads :-) unreliable)
    Permanently greyed out.
    I Followed the tips in support.apple.com/kb/TS1559 Unable to use Wi-Fi or Bluetooth with iPhone or iPod touch because there's no address listed for the device - you may want to try.
    No luck for me!!
    Called my supplier - who basically just refer you to the above articel, sigh.
    They have said that that process performs a complete software reset and so it must be a HW problem. Have to take it back under warranty.

    I reckon he may be right.

    Hmmm - Buying apple used to mean 'it just works' - welcome to land of mass production....
  4. #4  
    justanotherjack's Avatar
    iPhone Nanite

    2 Posts


    I've just jailbroken my iPhone and run into this exact same problem. The solution is rather simple.

    Go to Settings->General->Reset->Reset Network Settings.

    Enter your passcode, your phone will reboot and you should then start picking up Wifi networks.

    I hope this is helpful!

Posting Permissions