Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    michaels1mom's Avatar
    iPhone Nanite

    1 Posts

    Default can't update to OS 2.2

    Quite the novice, but not an *****. Received an iPhone 3G for Christmas...everything was going ok until I tried to install some apps and rec'd the error msg that I needed to update to OS 2.2. Easy, I thought.

    At the time, I had a regular PC and connected iPhone to iTunes and immediately was given the prompt of updating to OS 2.2, which I tried to do. Didn't work. Gets stuck in the "backing up iPhone mode".....So, I was sort of like, the heck with it. Like I said, I am just a novice...can really do without those apps.

    For my birthday in April I rec'd a macbook. Now, I thought I could finally update my iphone to get those apps I want that won't download without OS 2.2 ..... Guess what... no such luck....Won't update even with the mac.

    I even spent 30 minutes with apple on the phone today and I swear that lady must have been reading a flow sheet and she really was no help and I finally had to go because I had to meet my young children at the bus stop.

    Any suggestions? Should I call apple back? We have no apple store nearby or else I would go there. I am getting quite frustrated because I think it should be an easy fix.
    My iphone isn't loaded with anything extra-ordinary. Only about 20 songs, for goodness sakes!

    Thanks, Michele
  2. #2  
    chobbs1's Avatar
    iMore Guru

    1,661 Posts
    Global Posts
    1,664 Global Posts


    how long did you wait during the back up portion of the update? sometimes that can take quite a while especially if it has not yet been done. just a thought.

    other than that i would try and contact apple again and go through the flow sheet with someone again. good luck and let us know how it goes.
  3. #3  
    msbaylor's Avatar
    Forum App Reviewer

    540 Posts
    Global Posts
    542 Global Posts


    I've had the same issue and I've actually known others with the same issue. The fix- try a different iPhone sync cord. it was like ours had gone bad or something. While I never had trouble using it to charge though.

Posting Permissions