Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread AuthorThread Author   #1  
    bomba's Avatar
    iPhone Newbie

    19 Posts
    Global Posts
    22 Global Posts

    Default something is wrong :S

    i dont know if its just me but lately my ipod has been dropping the safari and youtube but stayed connected to wi-fi. like i will load a webpage and then safari will quit and send me back to the home screen any ideas on whats going wrong?
  2. #2  
    hey_WILL's Avatar
    iPhone Intermediate

    112 Posts
    Global Posts
    113 Global Posts


    so i am guessing it's a touch..
    so, any error messages?
    you may need to just search again for a connection, go to the settings and make sure everything is right with the internet settings.
    maybe it is your router. check in different wifi hotspots.
    i am not an ipod touch user, but those are the first things i would do..
  3. #3  
    Rene Ritchie's Avatar
    iMore Actual

    1,887 Posts
    Global Posts
    2,452 Global Posts


    Sounds like Safari is crashing. When an App crashes, the Mobile OS X tries to make it "elegant" but just shutting it down and sending you back to the Home screen. Some pages are just so (I would say poorly, but I'll be kind and say aggressively or busily) coded that they overwhelm Mobile Safari and crash it. Facebook profile pages, when filled to the brim with cr@p, do this a lot to me.

    Hopefully the next version of Mobile Safari, with the SquirelFish Javascript engine will prove hardier. Or pages will get less cr@ppy.

    You can also try going in to Settings > Safari and clearing your cache and cookies, to make sure all the gunk isn't bugging you up.
  4. #4  
    secretmuscle's Avatar
    iPhone Newbie

    22 Posts


    sure wish firefox was avail.
  5. #5  
    Tramain's Avatar
    iMore Genius

    3,337 Posts


    Might want to restore a restore always helps.

Posting Permissions