Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    3migo's Avatar
    iPhone Nanite

    1 Posts
    Global Posts
    487 Global Posts

    Default "No SIM" Problem

    For the past couple days, my 3GS has been randomly presenting the "No SIM" error message. The only fix that I have found for it, is to hard restart it, then it will work for a while, until the next time I get the error message.

    I have removed the SIM card and tray, cleaned it with canned air, and reinstalled it multiple times, and it has not had any effect. I have also restored my phone, yet it also hasn't helped.

    While restarting my phone isn't a huge deal, I never know how long my phone has been rendered useless each time it happens. I could notice it within 5 minutes, or it could take me 2 hours, and if someone needed to get in contact with me in that time, it can lead to a huge problem with my business.

    I have had this phone since September of 2009, with the same SIM card.

    Is anyone else having this problem, or has someone found a solution to it?
  2. #2  
    MYNAMESALEX's Avatar
    iPhone Intermediate

    137 Posts
    Global Posts
    156 Global Posts


    try a layer or two of scotch tape on the back of the sim card. The sim tray may be loose fitting, this is reportedly somewhat common with 3gs, so scotch tape on the back of the sim before you put it in helps pressure the metal contacts between the mobo and the SIM back together.

Posting Permissions