Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    Matthew Janssen's Avatar
    iPhone Nanite

    Posts
    1 Posts

    Default Mail Notification Bug

    Posting this here after emailing Rene and he requesting me to .

    There is a specific set of circumstances that are needed to reproduce this bug but they are not necessarily extraordinary circumstances (ones in which no one would ever set them up that way).

    1: Have at least 2 email accounts set up on your iOS device (I can reproduce the issue on my iPhone 5 and iPad 3 - iOS 6.0.2 and iOS 6.1, respectively)
    2: For both accounts, set your Notification Settings to - Notification Centre [ON], Alert Style [Banners], Badge App Icon [ON], New Mail Sound [shouldn't matter], Show Preview [shouldn't matter].
    3: But this is where the trouble happens: for the first account set View in Lock Screen to [ON], for the second account set that to [OFF]. You could switch these vice versa but they just have to be different settings for each account.
    4: With your device locked (very important), receive an email on the account where View in Lock Screen is OFF. You will hear the New Mail sound. Now, unlock the device. Notice anything not happen? Right, no banner notification. The icon is still badged and the 'notification' even still shows up in Notification Centre but there is no banner notification to speak of.

    I mentioned that the circumstances have to be specific. For example, the banners appear as normal if the device is unlocked while the email comes in. The banners also appear as expected (even after the device is unlocked) if both email accounts have set the View in Lock Screen setting to [OFF]. The bug only occurs when one email account is set to [ON] and one is set to [OFF].

    This bug has been driving me crazy since iOS 6 launched last year. I will note that I did not have my notifications set up this way in iOS 5 so the bug could very well have been present even back then, but I've only noticed it since iOS 6.

    Back in November 2012, I spent quite a bit of time talking to an upper-level AppleCare Support Tech about the issue. He was corresponding back and forth with the development team for a few weeks (having me try some different things) but since the (American) Thanksgiving holiday, I haven't heard from him. I also filed a bug report with Apple around the same time but there's really been no response.

    I guess I'm just trying to get the word out there and see if I'm crazy or if this is really the real deal

    I was going to include screenshots of my Notification Settings for each of my accounts but I think my explanation above should be enough to get them set up correctly to reproduce the bug.
  2. #2  
    Alli's Avatar
    iMore Genius

    Posts
    11,054 Posts
    Global Posts
    13,726 Global Posts
    iOS Version
    6.x

    Default Re: Mail Notification Bug

    Have you tried changing just one feature at a time so you see when it starts?

Similar Threads

  1. Replies: 0
    Last Post: 10-23-2011, 06:23 PM
  2. Replies: 4
    Last Post: 10-20-2011, 07:39 AM
  3. Mail notifications appearing twice
    By bigg22 in forum iOS 5
    Replies: 1
    Last Post: 10-16-2011, 05:43 PM
  4. mbox mail serious bugs
    By calum86 in forum iPhone Apps & Games
    Replies: 0
    Last Post: 09-26-2009, 09:26 AM
  5. Weird mail notification badge issue
    By haplo53 in forum iPhone 4
    Replies: 6
    Last Post: 02-12-2009, 04:44 PM

Posting Permissions