1. allison cross's Avatar
    I'm with Comcast ....having the same issues since the update
    B.builder_1 likes this.
    01-04-2013 07:08 PM
  2. Jacy LeMaire's Avatar
    I'm having the same problem. I just updated iPad to iOS 6.0, but didn't fix. I've been having the same problem with my iPhone 4 prior and to get the picture to send I have to connect to 3G. The Internet is provided through Comcast . Quite frankly, this blows.
    01-09-2013 08:56 PM
  3. Shell148's Avatar
    I spoke with Comcast about this issue. Apparently, according to Comcast, this issue is specific to their "Arris" modems. They tell me that going to your local Comcast facility and exchanging it for the "SMC" modem corrects the issue of not being able to send pictures (or texts in some cases) via "I message". They say that it is a know incompatibility issue (with the product "Arris" versus Apple or Comcast) and this obviously is much cheaper and easier than using a bridge and buying a second modem-if you rent a modem. I am going to try this, as it makes sense to try this versus spending and extra 100 bucks for a second bridge modem. I hope this helps!!
    01-17-2013 02:28 PM
  4. suellen54's Avatar
    I'm having the exact same problem and Comcast is my Internet provider. So annoying!
    01-21-2013 05:48 PM
  5. Amy Louise1's Avatar
    I have been unable to send pictures via iMessage on my iPhone (4S on iOS 6) as well as on my ipad (4/ ios 6). In order to send the picture on my phone I have to either disconnect from wifi or do "send as text." On the ipad, I can't send pictures through imessage at all, because I have the version that uses wifi. This is SO annoying. I spend so much money on these products and to have a problem as large as this is extremely frustrating.

    I do have Comcast at home, which is the primary connection I use. All other functions that use the wifi connection work. I have reset everything, done a restore, logged out of my apple ID on both devices (did a hard reset after and then signed back in, all of these thing so no avail. I have called Comcast, they also reset the modem and said the connection is working properly (which makes sense since everything works except THIS!). There are SO many forums about this- and it's been a problem for quite a while. My question is, why don't we have an update fixing this substantial issue?

    PS. Changed modems and problem is still here!
    01-26-2013 09:19 PM
  6. cblaird's Avatar
    I can't send photos from my iPad. Since I updated to iOS 6 this started the issue.. My provider is verizon. This is a big problem
    02-08-2013 05:48 PM
  7. Lozenger19's Avatar
    iOS 6.1 and still sending everything (including photos via wifi)
    02-08-2013 10:36 PM
  8. heathenskeep's Avatar
    i use century link internet and cant send pics either
    02-13-2013 12:50 PM
  9. bjcdaigs's Avatar
    I am now having the same issue that I can't receive or send pics on iMessage. I do not have Comcast... I have Charter Cable... But, I have the mini with Verizon 3G and when I shut off wifi and use the cellular it still won't let me send/receive pics on iMessage. I read that someone mentioned changing some setting? What setting do I change? I have had this mini since Feb 3 and this feature worked until 2 days ago and then just stopped allowing... Any help out there?
    03-21-2013 10:20 AM
  10. 1TexasGirl's Avatar
    I am having the same issues with my iPhone. I have AT&T as a carrier and Comcast as my Internet provider. Cannot send pics over wifi and it is extremely frustrating.
    06-14-2013 07:50 PM
  11. Peligro911's Avatar
    I am having the same issues with my iPhone. I have AT&T as a carrier and Comcast as my Internet provider. Cannot send pics over wifi and it is extremely frustrating.
    Get a new modem from Comcast


    Sent from my iPhone 5 from a galaxy far far away (in the USA ) using Tapatalk !
    06-14-2013 09:26 PM
  12. khruiz's Avatar
    Yes, my home Internet provider is also Comcast and cannot send pictures to my husband who as an Android ( very frustrating). I can however send iMessages to iPhone users. I have not tested it out with other WiFi providers.
    08-19-2013 01:17 PM
  13. missxhillary's Avatar
    Okay, I just got my phone a few days ago and it's running 6.1.3 I can use all data except i cannot send pictures, on or off imsg. Only if i turn off my wifi and connect to my data. This is extremely frustrating. I'm also not with comcast, I use arris modem and dlink router. The modem is brand new swapped out last week as i was having internet issues. The dlink router has recently been installed as i swapped out my other one.

    My friend has the same phone, same version and is able to send out pictures on her wifi. If anyone figures this out please post instructions. I need to get this working as I use wifi at home & need to send pictures for work.
    09-05-2013 02:26 PM
  14. Jobine's Avatar
    Same problem... IOS 8.3 and 2 years later !
    05-23-2015 11:54 AM
  15. Just_Me_D's Avatar
    Same problem... IOS 8.3 and 2 years later !
    What problem would that be and what have you done to correct that problem?
    05-23-2015 12:10 PM
  16. Jobine's Avatar
    What problem would that be and what have you done to correct that problem?
    Many things.
    Reset network settings
    Turn on And off iMessage
    All send picture still not delivered

    On 3G all works
    05-23-2015 12:17 PM
  17. Just_Me_D's Avatar
    Many things.
    Reset network settings
    Turn on And off iMessage
    All send picture still not delivered

    On 3G all works
    iMessage to iMessage should work just fine over Wi-Fi, but if you're trying to send photos via the Messages app to an non-Apple device, it will not work. Does your ISP have a limit on attachment sizes? Is there a setting of some sort on your router or firewall that's preventing the photos from being sent via Wi-Fi? Is the problem occurring on any Wi-Fi network or just your own?
    05-23-2015 12:23 PM
  18. Jobine's Avatar
    iMessage to iMessage don't work (same home or not)
    All Apple devices
    I go try on another wifi
    05-23-2015 12:35 PM
  19. Just_Me_D's Avatar
    iMessage to iMessage don't work (same home or not)
    All Apple devices
    I go try on another wifi
    Barring a corrupted iOS version, I can only assume that the recipient does not have iMessage enabled. In any case, I would do a clean install of the latest iOS version and set it up as new.
    05-23-2015 12:46 PM
  20. Jobine's Avatar
    All works good on another wifi network !?!
    05-23-2015 08:26 PM
  21. Just_Me_D's Avatar
    All works good on another wifi network !?!
    If that's the case then the problem lies with your Wi-Fi network. Unplug it and the cable/DSL modem for about a minute and then plug them both back in. Afterwards, try to send an iMessage to an iOS recipient.
    05-23-2015 08:39 PM
  22. Jobine's Avatar
    I unplug my cable modem and my router, try iMessage... don't work !
    05-24-2015 07:33 PM
  23. Jobine's Avatar
    I turn off my Firewall on my Asus Router and I can send, but not receive.
    05-25-2015 06:08 AM
48 12
LINK TO POST COPIED TO CLIPBOARD