Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread AuthorThread Author   #1  
    Bugeyeblue's Avatar
    iPhone Intermediate

    Posts
    163 Posts
    Global Posts
    319 Global Posts

    Default Text alert twice after removing lock screen notifications

    I removed lock screen notifications to keep them from being viewed without a password. Now when I unlock my phone, I get an alert for the second time. The first time being when the phone is locked, the second time being when I unlock the phone. Is there any way to prevent this?
  2. #2  
    BLiNK's Avatar
    iMore Genius

    Posts
    8,262 Posts
    Global Posts
    8,609 Global Posts
    iOS Version
    iOS 182

    Default

    this is THE million dollar question. i have yet to see a fix or workaround for this, jailbreak or not. very frustrating. i guess in a way i understand the reasoning behind this--if 'View in Lock Screen' is turned to OFF then notification, or notifications, will be visible once the device is opened/unlocked. it'd be nice if Apple gave a their users a little more control over this

    unless i am missing something, this is just the way it is. plain & simple
  3. Thread AuthorThread Author   #3  
    Bugeyeblue's Avatar
    iPhone Intermediate

    Posts
    163 Posts
    Global Posts
    319 Global Posts

    Default

    On well, glad its not just me. Thanks.
  4. #4  
    hellomiggy's Avatar
    iPhone Intermediate

    Posts
    158 Posts
    Global Posts
    293 Global Posts
    iOS Version
    6.0 b.1

    Default

    I tried checking out your dilemma, have you tried turning off your alert style to None, and on the View on lock screen, set that to off. You will get notified via whatever sound you have, plus if you have your badges on you will be reminded with the texts getting sent to you.

    *Tested out on 5.1b3*
  5. Thread AuthorThread Author   #5  
    Bugeyeblue's Avatar
    iPhone Intermediate

    Posts
    163 Posts
    Global Posts
    319 Global Posts

    Default

    Quote Originally Posted by migueljonathan View Post
    I tried checking out your dilemma, have you tried turning off your alert style to None, and on the View on lock screen, set that to off. You will get notified via whatever sound you have, plus if you have your badges on you will be reminded with the texts getting sent to you.

    *Tested out on 5.1b3*
    What do you mean by alert style? The sound? If you turn the sound off, how would you know that you got a notification? Thanks for the help so far.
  6. #6  
    BLiNK's Avatar
    iMore Genius

    Posts
    8,262 Posts
    Global Posts
    8,609 Global Posts
    iOS Version
    iOS 182

    Default

    Settings>Notifications>(desired app)>Alert Style>(None, Banners or Alerts)

    which i would assume you would still want Banner style notifications while in app or homescreen. this method would not allow that

    if you're jailbroken you may want to look into Popup Blocker. it will allow you to block notifications on the lockscreen without the alert once you Slide to Unlock the device. you can even set it up to "Wake" the device even without the notification showing, or you can choose to not
    Thanked by:
    Bugeyeblue (02-28-2012)
  7. Thread AuthorThread Author   #7  
    Bugeyeblue's Avatar
    iPhone Intermediate

    Posts
    163 Posts
    Global Posts
    319 Global Posts

    Default

    Quote Originally Posted by BLiNK View Post
    Settings>Notifications>(desired app)>Alert Style>(None, Banners or Alerts)

    which i would assume you would still want Banner style notifications while in app or homescreen. this method would not allow that

    if you're jailbroken you may want to look into Popup Blocker. it will allow you to block notifications on the lockscreen without the alert once you Slide to Unlock the device. you can even set it up to "Wake" the device even without the notification showing, or you can choose to not
    Thanks, I'll check it out. Sounds like what I'm looking for. I was trying to use typophone 4 lockscreen and didn't like how the notifications stacked right over the best part of the lock screen.
  8. #8  
    Arelunde's Avatar
    iMore Intermediate

    Posts
    106 Posts
    Global Posts
    1,632 Global Posts
    iOS Version
    7.1

    Default

    I have only missed phone calls and text messages to show on the lock screen, but email and calendar events are set to show in the notification panel. I have badges enabled so I know there are waiting messages in email, text/iMessages and/or missed phone calls.
    Always learning ...
  9. #9  
    BLiNK's Avatar
    iMore Genius

    Posts
    8,262 Posts
    Global Posts
    8,609 Global Posts
    iOS Version
    iOS 182

    Default

    Quote Originally Posted by Arelunde View Post
    I have only missed phone calls and text messages to show on the lock screen, but email and calendar events are set to show in the notification panel. I have badges enabled so I know there are waiting messages in email, text/iMessages and/or missed phone calls.
    so other than your missed calls and text messages you have your Alert Styles set to NONE? and have your View in Lock Screen to OFF?

    if so then you obviously do not get any type of visible alert while in app or at your homescreen

Posting Permissions