1. kazmi's Avatar
    Hi!

    I was curious since I was able to previously save drafts while using google apps email on my computer and then accessing them later via the iphone, completing them and sending them out. I see that this is no longer the case. Is this an iOS5 limitation or has something changed? I have the google apps email account set up as an exchange account and it was working just fine before. I don't remember this from iOS4 but there might have been an option to sync the drafts folder when you check under settings>mail>Gmail...but it's not there anymore.

    Can any one help elucidate this issue? Any ways to get that functionality back without setting the account up as IMAP?

    Many thanks!
    11-11-2011 09:01 AM
  2. noaim's Avatar
    weird when I open mail go to where I can see all my accounts and go to the gmail account on bottom all folders are there including drafts
    11-11-2011 12:53 PM
  3. kazmi's Avatar
    Is that gmail account set up as an IMAP account or as your exchange account? My issue is that I have a personal gmail account (setup as IMAP) and a work email account which is a google apps account. Due to this, I can only set up one of these as an exchange account (server details are the same so iOS doesn't accept both). Now with my gmail account I can see the Drafts folder and use it as I want. However, I just noticed that with my google apps work account, I cannot access all the drafts. I only see 2 (there are 24 total) and those are older ones...it refreshes but doesn't pull any from the server.
    11-11-2011 01:57 PM
  4. Ipheuria's Avatar
    It's not only GMail I have the same problem with my work email which is an exchange account. I can't get the drafts which I can see in Outlook. If I make one on my iDevice it will show up in Outlook but not the other way around. I'm sorry to say I haven't found a fix. The only thing I can think of and I'm about to test it. If you go into the settings for the account it has the number of days to sync. Mine was set to 3 Days so I'm thinking anything older than 3 days wont be synced to the device. Mostmof my drafts are older than 3 days. I'll let you know what happens.

    Bingo! make the change and see if it works for you
    Last edited by Ipheuria; 11-11-2011 at 04:24 PM.
    11-11-2011 04:18 PM
  5. noaim's Avatar
    Is that gmail account set up as an IMAP account or as your exchange account? My issue is that I have a personal gmail account (setup as IMAP) and a work email account which is a google apps account. Due to this, I can only set up one of these as an exchange account (server details are the same so iOS doesn't accept both). Now with my gmail account I can see the Drafts folder and use it as I want. However, I just noticed that with my google apps work account, I cannot access all the drafts. I only see 2 (there are 24 total) and those are older ones...it refreshes but doesn't pull any from the server.
    i have two emaila ccounts setup in my device both from google and there exchange so why cant you set both as exchange?


    both mine are exchange and I can see the drafts folder...
    11-11-2011 04:25 PM
  6. Massie's Avatar
    This is an old thread, but the problem persists: if I begin an email on my iPhone using a Google account set up using Exchange, any draft I save does not get synced to Gmail on my laptop--it only lives on my device.

    It's not really a "bug" as it's simply not supported right now. My question is, has anyone come up with a usable workaround other than emailing the draft to yourself? It was an issue for me today because I needed to add some clickable text to an email and couldn't do that on my phone.
    12-01-2012 12:21 PM
  7. John Yester's Avatar
    Yep not supported. This is limitation of GMail via Exchange on iOS.

    The only way to have draft support is to use the GMail template when adding a new mail account.
    12-01-2012 12:45 PM
LINK TO POST COPIED TO CLIPBOARD