Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread AuthorThread Author   #1  
    AZMerf's Avatar
    iPhone Intermediate

    Posts
    176 Posts

    Default Time zones and daylights savings time

    I did the update on iPhone 4 (I have this on my 4S now too) and noticed times on calendar are an hour off. Checked in setting and set to auto update and says Cupertino. I live in Phoenix. Of I turn auto update off it goes to Phoenix. But then will it change as I travel???
  2. #2  
    bonesb
    bonesb's Avatar
    Guest

    Default

    There's a few things going on. First, you found one - General Time Zone is set to "Set Automatically". Second, here's your PITA - if you want your meetings to "travel with you" and adjust with you, set Calendar Time Zone Support to "Off" - otherwise every calendar event will be displayed according to the time zone selected for the event (when set to "Off" the events will be displayed according to the time zone you're in. Third, if you're traveling you ought to consider enabling the "Setting Time Zone" Locations Services System Services. And, fourth - network time is pushed by your network, not the iPhone (or any other mobile phone) - if you're roaming, say on USCC and you're a SPCS or VZW customer, the network time update may not be supported on USCC - and the update may not happen immediately even if you're on your native provider, I've had updates pushed hours after the bump occurred. And, Apple may have overlooked the network adjustment in their software - they boofed a time bump a couple of years ago and it was national news.

    One of the above is likely the source/fix of your issue. Also, reboot your device and/or reset network settings. And, if you're on SPCS or VZW, update your PRL (if you're in a native service area, of course) - they both had updates just a few days ago.
  3. #3  
    phessler's Avatar
    iMore Intermediate

    Posts
    118 Posts
    Global Posts
    146 Global Posts

    Default

    I had the same issue. After updating the PRL the Automatic setting worked correctly.
  4. #4  
    FritzDaCat's Avatar
    iMore Beginner

    Posts
    73 Posts
    iOS Version
    7.0.2

    Default

    Quote Originally Posted by bonesb View Post
    And, if you're on SPCS or VZW, update your PRL (if you're in a native service area, of course) - they both had updates just a few days ago.
    Worked for me too.

    For those who inevitably ask:

    Here are some basic instructions on how you can update your Preferred Roaming List:

    Power on your Verizon Wireless phone.
    Dial *228 from your home digital coverage area, followed by the SEND key. This call is airtime free.
    When prompted, press option 2 to update your phones roaming capabilities (This process may take up to 2 minutes).
    Once completed, a confirmation message will be played informing you that your phone has been programmed.
  5. #5  
    kch50428's Avatar

    Posts
    11,025 Posts
    Global Posts
    11,906 Global Posts
    iOS Version
    7.0

    Default

    Quote Originally Posted by FritzDaCat View Post
    Worked for me too.

    For those who inevitably ask:

    Here are some basic instructions on how you can update your Preferred Roaming List:

    Power on your Verizon Wireless phone.
    Dial *228 from your home digital coverage area, followed by the SEND key. This call is airtime free.
    When prompted, press option 2 to update your phones roaming capabilities (This process may take up to 2 minutes).
    Once completed, a confirmation message will be played informing you that your phone has been programmed.
    And for those who inevitably ask...

    Here's how to check which version you have:

    on iOS5 - go to >>Settings >> General >> About >> tap where it says 'Carrier' to scroll through... the current national PRL for most people should be 52559. If you have one that's 65*** - that would be for folks in areas that were Alltel and acquired by Verizon.
    Keith - iMore Moderator - The Mobile Nations/iMore Forum Rules
     iPhone5 on VZW;  iPad(2012) - wifi with BadElf for GPS
    "When the debate is lost, slander becomes the tool of the loser." -- Socrates
  6. Thread AuthorThread Author   #6  
    AZMerf's Avatar
    iPhone Intermediate

    Posts
    176 Posts

    Default

    I am on AT&T. The basic problem is if I set the General Time Zone to Automatic, it shows Cupertino California. I am in Phoenix, Arizona. I'll have to look on the AT&T site for a similar update to the roaming list. Thanks.
  7. #7  
    kch50428's Avatar

    Posts
    11,025 Posts
    Global Posts
    11,906 Global Posts
    iOS Version
    7.0

    Default

    Quote Originally Posted by AZMerf View Post
    I am on AT&T. The basic problem is if I set the General Time Zone to Automatic, it shows Cupertino California. I am in Phoenix, Arizona. I'll have to look on the AT&T site for a similar update to the roaming list. Thanks.
    Arizona is a special case... a few areas observe DST - the rest does not.

    Read more: Why Arizona doesn't observe Daylight Saving Time

    Unlike almost everywhere else, Arizona doesn't observe Daylight Saving Time (DST), and hasn't done so for the last 40 years.

    Arizona's independence from DST can cause a lot of confusion for both residents and visitors.
    It means the state is in the same time zone as Denver from November to March, but then falls behind Denver to Los Angeles time from March to November.
    Keith - iMore Moderator - The Mobile Nations/iMore Forum Rules
     iPhone5 on VZW;  iPad(2012) - wifi with BadElf for GPS
    "When the debate is lost, slander becomes the tool of the loser." -- Socrates
  8. #8  
    noaim's Avatar
    iMore Specialist

    Posts
    1,477 Posts
    Global Posts
    9,503 Global Posts
    iOS Version
    6.0

    Default

    when I set to automatic... the time zone is greyed out and not in use.. so where are you seeing cupertino california?
    I answer questions to the best of my knowledge if im wrong please correct me

Tags for this Thread

Posting Permissions