1. NickB2005's Avatar
    Hey all - I just upgraded to the public beta last night and for some reason whenever I get an email via the mail app that my work exchange account is tied to I don't get push notifications anymore. I checked and it is turned on, but for some reason I am just not getting them. Any ideas?
    07-08-2016 11:01 AM
  2. Vinu Jacob's Avatar
    To get notifications, you need to be connected to a Wi-Fi or cellular network. If youre not getting notifications for a specific app, try these steps:
    1. Make sure that the app supports notifications. Go to Settings > Notifications, select the app, and make sure that Notifications are turned on.
    2. Make sure that youre signed in to your Apple ID on your iOS device. Go to Settings > iTunes & App Stores and enter your Apple ID and password.
    3. Make sure that Do Not Disturb is turned off. Go to Settings > Do Not Disturb and tap Manual if it's turned on.
    4. If youve recently installed an app or restored from a backup, open the app to start getting notifications.


    Hope this helps in resolving your issue, as I am using ios10 on my iphone and do not have any issues with notification as of now.
    07-08-2016 11:05 AM
  3. NickB2005's Avatar
    I don't have any issues with notifications. I get them and when I go into my mail app and pull the data for new emails then they pop up, but for some reason now on iOS 10 I am not getting the push notifications specifically for that app.
    07-08-2016 11:07 AM
  4. emanwis's Avatar
    I am getting push emails for my work exchange account just fine.
    07-08-2016 12:29 PM
  5. wolfee48's Avatar
    Have you tried removing the account and then adding the account back?
    07-08-2016 12:39 PM
  6. kurt_19's Avatar
    I upgraded to 10 over the weekend. I wiped my phone clean today (deleting everything), reinstalled apps etc. setup my Exchange email and it will not send nor receive any emails. Yahoo and Gmail email accounts work fine.

    I have done this 100 times at my company with no issue on previous IOS's. Any suggestions, I am all ears!!!
    07-12-2016 07:02 PM
  7. Just_Me_D's Avatar
    I upgraded to 10 over the weekend. I wiped my phone clean today (deleting everything), reinstalled apps etc. setup my Exchange email and it will not send nor receive any emails. Yahoo and Gmail email accounts work fine.

    I have done this 100 times at my company with no issue on previous IOS's. Any suggestions, I am all ears!!!
    Go to Settings→ General → Reset, and then select "Reset Network Settings".
    07-12-2016 07:13 PM
  8. robertk328's Avatar
    Are the emails themselves not being pushed or is it just the notifications? There are two different settings there.
    07-12-2016 07:14 PM
  9. kurt_19's Avatar
    Just wiped the phone again and reset up. still nothing.

    did what you said Just_Me_D and it is now working.

    Why would resetting the network settings make the difference even after wiping the phone?
    07-12-2016 07:18 PM
  10. robertk328's Avatar
    Just wiped the phone again and reset up. still nothing.

    did what you said Just_Me_D and it is now working.

    Why would resetting the network settings make the difference even after wiping the phone?
    Glad it's working!
    07-12-2016 07:42 PM
  11. Just_Me_D's Avatar
    Just wiped the phone again and reset up. still nothing.

    did what you said Just_Me_D and it is now working.

    Why would resetting the network settings make the difference even after wiping the phone?
    If you simply chose to erase all contents and settings, you merely erased your data and non-native settings. That may not have flushed any native settings. Still, I'm only speculating. Anyway, I'm glad you got the problem resolved. Take care...
    07-12-2016 07:44 PM
  12. Ed Brennan's Avatar
    Mine worked ok with exchange, with one issue, that's being I can't search for example an email sent to a particular person, each time the mail app would crash and close, back on iOS 9 unfortunately
    07-17-2016 08:46 AM
  13. Jamee Berggren's Avatar
    Hey all - I just upgraded to the public beta last night and for some reason whenever I get an email via the mail app that my work exchange account is tied to I don't get push notifications anymore. I checked and it is turned on, but for some reason I am just not getting them. Any ideas?
    Reset network settings worked for me.
    Settings> general> reset> reset network settings
    09-18-2016 10:38 PM
  14. Jamee Berggren's Avatar
    Worked!!!
    09-18-2016 10:40 PM
  15. Stephen Chukumba's Avatar
    Reset network settings worked for me.
    Settings> general> reset> reset network settings
    I've been having the same issue with my work email on the iPhone 7 running iOS 10. I deleted and reinstalled the email account. reset network settings and unfortunately no luck.

    Another ideas out there?
    10-04-2016 11:20 PM
  16. msolomon's Avatar
    I've been having the same issue with my work email on the iPhone 7 running iOS 10. I deleted and reinstalled the email account. reset network settings and unfortunately no luck.

    Another ideas out there?
    11-06-2016 04:51 PM
  17. msolomon's Avatar
    I have the same issue with no help from Apple or AT&T. Cannot send or receive emails via cellular network. As soon as I get on to a wifi network, 50-60 email poor in?

    Any suggestions?
    11-06-2016 04:53 PM
  18. jrdatrackstar1223's Avatar
    I have somewhat of a similar issue. I have my Exchange/Outlook email forwarding to my iCloud email address. I will notice that emails are not coming through unless I open the mail app and then my emails start coming through. The other weird thing is that when I go to iCloud.com and go to my email, the badge is always a larger number than my phone.
    11-07-2016 09:31 AM
  19. Bruno G1's Avatar
    Found my problem under Settings --> Cellular --> section "Use cellular data for:" I had turned off mail over cellular a while ago and clearly forgot about it.
    11-09-2016 08:39 AM

Similar Threads

  1. How can I get my 6s working?
    By iMore Question in forum iPhone 6s
    Replies: 3
    Last Post: 07-15-2016, 12:04 PM
  2. Revert to 9.3 from 10 beta 1?
    By iMore Question in forum iCloud
    Replies: 2
    Last Post: 07-08-2016, 05:47 AM
  3. Why doesn't my iPhone recognize my new email address?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 07-08-2016, 05:45 AM
  4. iPhone 5s is not recognized by iTunes in Mac machine, why?
    By iMore Question in forum iPhone 5s
    Replies: 1
    Last Post: 07-08-2016, 05:23 AM
  5. How secure is the IOS 9.3.3 /10 BETA?
    By iMore Question in forum iOS 9
    Replies: 1
    Last Post: 07-08-2016, 01:38 AM
LINK TO POST COPIED TO CLIPBOARD