Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
Like Tree2Likes
  • 1 Post By Just_Me_D
  • 1 Post By kurt_19
  1. Thread AuthorThread Author   #1  
    NickB2005's Avatar
    iMore Intermediate

    Posts
    137 Posts

    Default IOS 10 beta - push email (exchange) not pushing anymore

    Hey all - I just upgraded to the public beta last night and for some reason whenever I get an email via the mail app that my work exchange account is tied to I don't get push notifications anymore. I checked and it is turned on, but for some reason I am just not getting them. Any ideas?
  2. #2  
    Vinu Jacob's Avatar
    iMore Beginner

    Posts
    86 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    To get notifications, you need to be connected to a Wi-Fi or cellular network. If youre not getting notifications for a specific app, try these steps:
    1. Make sure that the app supports notifications. Go to Settings > Notifications, select the app, and make sure that Notifications are turned on.
    2. Make sure that youre signed in to your Apple ID on your iOS device. Go to Settings > iTunes & App Stores and enter your Apple ID and password.
    3. Make sure that Do Not Disturb is turned off. Go to Settings > Do Not Disturb and tap Manual if it's turned on.
    4. If youve recently installed an app or restored from a backup, open the app to start getting notifications.


    Hope this helps in resolving your issue, as I am using ios10 on my iphone and do not have any issues with notification as of now.
  3. Thread AuthorThread Author   #3  
    NickB2005's Avatar
    iMore Intermediate

    Posts
    137 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    I don't have any issues with notifications. I get them and when I go into my mail app and pull the data for new emails then they pop up, but for some reason now on iOS 10 I am not getting the push notifications specifically for that app.
  4. #4  
    emanwis's Avatar
    iMore Beginner

    Posts
    96 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    I am getting push emails for my work exchange account just fine.
  5. #5  
    wolfee48's Avatar
    iMore Intermediate

    Posts
    206 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    Have you tried removing the account and then adding the account back?
  6. #6  
    kurt_19's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    I upgraded to 10 over the weekend. I wiped my phone clean today (deleting everything), reinstalled apps etc. setup my Exchange email and it will not send nor receive any emails. Yahoo and Gmail email accounts work fine.

    I have done this 100 times at my company with no issue on previous IOS's. Any suggestions, I am all ears!!!
  7. #7  

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    Quote Originally Posted by kurt_19 View Post
    I upgraded to 10 over the weekend. I wiped my phone clean today (deleting everything), reinstalled apps etc. setup my Exchange email and it will not send nor receive any emails. Yahoo and Gmail email accounts work fine.

    I have done this 100 times at my company with no issue on previous IOS's. Any suggestions, I am all ears!!!
    Go to Settings→ General → Reset, and then select "Reset Network Settings".
    Jamee Berggren likes this.
  8. #8  

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    Are the emails themselves not being pushed or is it just the notifications? There are two different settings there.
  9. #9  
    kurt_19's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    Just wiped the phone again and reset up. still nothing.

    did what you said Just_Me_D and it is now working.

    Why would resetting the network settings make the difference even after wiping the phone?
    Just_Me_D likes this.
  10. #10  

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    Quote Originally Posted by kurt_19 View Post
    Just wiped the phone again and reset up. still nothing.

    did what you said Just_Me_D and it is now working.

    Why would resetting the network settings make the difference even after wiping the phone?
    Glad it's working!
  11. #11  

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    Quote Originally Posted by kurt_19 View Post
    Just wiped the phone again and reset up. still nothing.

    did what you said Just_Me_D and it is now working.

    Why would resetting the network settings make the difference even after wiping the phone?
    If you simply chose to erase all contents and settings, you merely erased your data and non-native settings. That may not have flushed any native settings. Still, I'm only speculating. Anyway, I'm glad you got the problem resolved. Take care...
  12. #12  
    Ed Brennan's Avatar
    iMore Nanite

    Posts
    1 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    Mine worked ok with exchange, with one issue, that's being I can't search for example an email sent to a particular person, each time the mail app would crash and close, back on iOS 9 unfortunately
  13. #13  
    Jamee Berggren's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    Quote Originally Posted by NickB2005 View Post
    Hey all - I just upgraded to the public beta last night and for some reason whenever I get an email via the mail app that my work exchange account is tied to I don't get push notifications anymore. I checked and it is turned on, but for some reason I am just not getting them. Any ideas?
    Reset network settings worked for me.
    Settings> general> reset> reset network settings
  14. #14  
    Jamee Berggren's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    Worked!!!
  15. #15  
    Stephen Chukumba's Avatar
    iMore Nanite

    Posts
    1 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    Quote Originally Posted by Jamee Berggren View Post
    Reset network settings worked for me.
    Settings> general> reset> reset network settings
    I've been having the same issue with my work email on the iPhone 7 running iOS 10. I deleted and reinstalled the email account. reset network settings and unfortunately no luck.

    Another ideas out there?
  16. #16  
    msolomon's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore

    Quote Originally Posted by Stephen Chukumba View Post
    I've been having the same issue with my work email on the iPhone 7 running iOS 10. I deleted and reinstalled the email account. reset network settings and unfortunately no luck.

    Another ideas out there?
  17. #17  
    msolomon's Avatar
    iMore Nanite

    Posts
    2 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    I have the same issue with no help from Apple or AT&T. Cannot send or receive emails via cellular network. As soon as I get on to a wifi network, 50-60 email poor in?

    Any suggestions?
  18. #18  
    jrdatrackstar1223's Avatar
    iMore Beginner

    Posts
    76 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    I have somewhat of a similar issue. I have my Exchange/Outlook email forwarding to my iCloud email address. I will notice that emails are not coming through unless I open the mail app and then my emails start coming through. The other weird thing is that when I go to iCloud.com and go to my email, the badge is always a larger number than my phone.
  19. #19  
    Bruno G1's Avatar
    iMore Nanite

    Posts
    1 Posts

    Default Re: IOS 10 beta - push email (exchange) not pushing anymore?

    Found my problem under Settings --> Cellular --> section "Use cellular data for:" I had turned off mail over cellular a while ago and clearly forgot about it.

Similar Threads

  1. How can I get my 6s working?
    By iMore Question in forum iPhone 6s
    Replies: 3
    Last Post: 07-15-2016, 01:04 PM
  2. Revert to 9.3 from 10 beta 1?
    By iMore Question in forum iCloud
    Replies: 2
    Last Post: 07-08-2016, 06:47 AM
  3. Why doesn't my iPhone recognize my new email address?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 07-08-2016, 06:45 AM
  4. iPhone 5s is not recognized by iTunes in Mac machine, why?
    By iMore Question in forum iPhone 5s
    Replies: 1
    Last Post: 07-08-2016, 06:23 AM
  5. How secure is the IOS 9.3.3 /10 BETA?
    By iMore Question in forum iOS 9
    Replies: 1
    Last Post: 07-08-2016, 02:38 AM

Posting Permissions