1. truenorthstrong's Avatar
    Not working for me on iOS 10, still have to switch keyboards to type in different languages.
    Ursus Rufus likes this.
    07-08-2016 10:48 AM
  2. Vinu Jacob's Avatar
    In order to make this feature function, you need to make sure desired languages are enabled in iOS 10's new Dictionary menu under Settings, then add the correct keyboards under General > Keyboards. Once this is done, Apple's QuickType should both accept multiple languages and offer appropriate word suggestions.

    If this resolves your issue, please do let us know.
    Ursus Rufus likes this.
    07-08-2016 11:22 AM
  3. truenorthstrong's Avatar
    In order to make this feature function, you need to make sure desired languages are enabled in iOS 10's new Dictionary menu under Settings, then add the correct keyboards under General > Keyboards. Once this is done, Apple's QuickType should both accept multiple languages and offer appropriate word suggestions.

    If this resolves your issue, please do let us know.
    The language (Polish) is not under Dictionary but I have it selected under keyboards.
    07-08-2016 12:05 PM
  4. Vinu Jacob's Avatar
    I believe unified keyboard multi-lingual functionality is limited to languages that have both the dictionary as well as the keyboard in iOS. Perhaps Apple will add additional languages to the dictionary as they get closer to the final release.
    07-08-2016 12:13 PM
  5. truenorthstrong's Avatar
    Ya that could be it. I guess I am back using Swift Key for now.
    07-08-2016 02:40 PM
  6. lpelullo's Avatar
    It's a bit tricky. My phone's language is English, but I have many keyboards. When the keyboard is set to English, I can also type in Spanish or English, but none of the other keyboards I have. In fact, when I start to type in one of the other languages when the keyboard is set to English, it seems to assume it's Spanish and the options it gives me are all in Spanish.
    Multilingual typing-imageuploadedbyimore-forums1468009784.654169.jpg

    When the keyboard is set to Spanish I can, predictably, type without issue in both Spanish and English, but not Italian or French or any of the other languages.

    When the keyboard is set to Italian I can type in Italian or English, but I can't type in Spanish, etc.

    Multilingual typing-imageuploadedbyimore-forums1468009930.574758.jpg

    Multilingual typing-imageuploadedbyimore-forums1468009944.793722.jpg

    So it seems that whatever the language your phone is in is the one that will be able to be typed in regardless of the keyboard language. I'm not sure why Spanish is the one I'm able to type in when the keyboard is in English, but maybe because my region is US and Spanish is the keyboard I use as much as or more than English.

    I'd love to be able to just type and not have to worry about the keyboard, but oh well.

    I do have a complaint, though. The Spanish predictions and corrections are absurd since the update. For example, if I accidentally type "cisas" instead of "cosas," it leaves it as "cisas" and even replaces the correct word.
    07-08-2016 03:41 PM
  7. TwitchyPuppy's Avatar
    Settings --> General --> Language & Region --> Preferred Language Order.

    I have English then French (and the only keyboard language I have set is English). So, with that order, the first suggestions when I'm ready to type are in English. However, I can easily switch to French by starting to type a French word. Try that
    Tartarus likes this.
    07-08-2016 04:51 PM
  8. lpelullo's Avatar
    I figured the preferred language order might have something to do with it, but I have multiple languages in that list. I guess it just takes the first two, though.
    07-08-2016 05:12 PM
  9. truenorthstrong's Avatar
    Settings --> General --> Language & Region --> Preferred Language Order.

    I have English then French (and the only keyboard language I have set is English). So, with that order, the first suggestions when I'm ready to type are in English. However, I can easily switch to French by starting to type a French word. Try that
    Ya doesn't work with English and Polish
    07-08-2016 07:33 PM
  10. TwitchyPuppy's Avatar
    Ya doesn't work with English and Polish
    Woah, that blows :S
    07-08-2016 08:09 PM
  11. truenorthstrong's Avatar
    Woah, that blows :S
    Yes it does thought I wouldn't have to use SwiftKey and stick with stock keyboard.
    07-10-2016 01:40 PM
  12. combi06's Avatar
    Typing works for me in English and Spanish but I cannot dictate a message in Spanish (only on English)
    07-12-2016 11:27 AM
  13. lpelullo's Avatar
    Typing works for me in English and Spanish but I cannot dictate a message in Spanish (only on English)
    I think that for dictation the keyboard still needs to be in Spanish. Or do you mean that you can't at all?
    07-12-2016 11:31 AM
  14. Ursus Rufus's Avatar
    Not working here.

    I have English French German and Italian enabled both in "Dictionary" & "Keyboard" settings ( Settings > General; they are both a bit more than halfway down)...

    Languages only work when I switch manually using the globe key.

    Two things that may be of interest:

    1. Unchecking then rechecking each language under "Dictionary" seems to reload them, as a small circle appears similar to the one when downloading an app. But doing this doesn't seem to change anything.

    2. Between each language (again under "Dictionary" is a translation dictionary. I also have each of these checked but again, it makes no difference:

    Not working.
    07-14-2016 12:17 AM
  15. Ursus Rufus's Avatar
    It is working. Here's what's up: My phone's language is English UK. If I'm using that keyboard I can only write in that language. If I switch to the next one down (French) I can write in English and French. And so on.
    07-22-2016 12:33 AM
  16. Ursus Rufus's Avatar
    Not working for me on iOS 10, still have to switch keyboards to type in different languages.
    See my post just above this one. Hope it helps.
    07-22-2016 12:34 AM
  17. combi06's Avatar
    I can dictate but only in English. I haven't tried your suggestion but if I need to have the Spanish language/keyboard installed and active then it sort of defeats the purpose of being able to use one keyboard for both (I uninstalled the Spanish language/keyboard since I was able to type in both using the same (English) keyboard.
    Ursus Rufus likes this.
    07-25-2016 03:49 PM
  18. Ursus Rufus's Avatar
    I uninstalled the Spanish language/keyboard since I was able to type in both using the same (English) keyboard.
    That's the opposite for me. Can't really say about dictating as I don't use that. But I just enabled the Spanish (Spain) keyboard (& dictionaries) to see what's up. I'm typing in English right now with the Spanish keyboard. However. Non Pissarro escrow en Espinosa (No puedo escribir en espaol) with the English (default) keyboard. Espero que esto est claro?
    07-26-2016 03:38 PM

Similar Threads

  1. Swipe typing/glide typing
    By jaleelhamid in forum iOS
    Replies: 5
    Last Post: 07-05-2016, 11:23 PM
  2. Replies: 2
    Last Post: 07-05-2016, 09:40 AM
  3. Trying to decide what type of iPad I should get for my child?
    By iMore Question in forum Ask a Question
    Replies: 8
    Last Post: 07-05-2016, 06:34 AM
  4. How do I make the type size bigger on the favorites bar?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 06-24-2016, 02:37 PM
  5. Swipe typing/glide typing
    By jaleelhamid in forum iPhone Apps & Games
    Replies: 1
    Last Post: 06-20-2016, 09:36 PM
LINK TO POST COPIED TO CLIPBOARD