1. lornaevo's Avatar
    So I updated to the latest version of iOS on my iPhone 4S. Now I can use iMessage with no problem. All my text to my wife goes as iMessage. If I try sending a picture, it either fails or goes as text message. Has anyone else experienced this or have a solution?

    Thanks
    03-21-2013 07:46 AM
  2. Just_Me_D's Avatar
    Have you tried rebooting your device and/or resetting your network settings?
    03-21-2013 07:58 AM
  3. lornaevo's Avatar
    Yes. I tried both of those. Also tried turning iMessage off and on again.
    03-21-2013 08:03 AM
  4. Just_Me_D's Avatar
    Yes. I tried both of those. Also tried turning iMessage off and on again.
    Okay, then go to Settings-Messages and make sure that "MMS Messaging" is turned on.
    03-21-2013 08:20 AM
  5. lornaevo's Avatar
    Yes. That is turned on.
    03-21-2013 08:28 AM
  6. Alli's Avatar
    Out of curiosity, what carrier are you using?
    03-21-2013 09:19 AM
  7. lornaevo's Avatar
    I'm on sprint.
    03-21-2013 09:30 AM
  8. Alli's Avatar
    You might want to call Sprint and see if they can check your network from their end.
    03-21-2013 12:39 PM
  9. lornaevo's Avatar
    Thanks alli. I reached out to them. awaiting. The strange thing is that inessage works. Just not for pics.
    03-21-2013 12:54 PM
  10. tcsm's Avatar
    There is an issue with iOS 6.1.3 which has broken photo iMessaging.
    Please see this article for further information: iOS 6.1.3 Affects iMessage Photo Sharing, Users Report - Softpedia

    At this stage there is no fix available and we are all waiting on Apple.
    03-21-2013 05:07 PM
  11. danluso's Avatar
    I have the same issue with 6.1.2 OS system...I have and iPad 3 that works with imessage sending over wifi with photos and video...But I can not make ny iPhone 5 work iMessage on wifi only for foto and video...it works on 3g though. all settings are the same on all devices.
    03-21-2013 05:19 PM
  12. John Yester's Avatar
    Just curious if it matters how the message is being sent from. iCloud, Number, or another email address. Just a thought since this issue seems so sporadic....
    03-21-2013 05:23 PM
  13. lornaevo's Avatar
    It's good to know that I'm not the only person having this issue.
    03-21-2013 06:32 PM
  14. lornaevo's Avatar
    Pretty strange. It just started working on its own.
    03-22-2013 08:35 AM
  15. Just_Me_D's Avatar
    Pretty strange. It just started working on its own.
    That's a good thing.......Thanks for the update.
    03-22-2013 08:55 AM
  16. gtshouse's Avatar
    Here's how I fixed mine. Turn off iMesage. Power off the phone for about 1 minute. Power back on, turn on iMessage.
    04-04-2013 10:36 PM
  17. John Yester's Avatar
    Same thing as doing a reset....Disconnects and reconnects. It's going to happen now and then. I have not had this issue at all
    04-05-2013 12:40 AM
  18. dmoskaluk's Avatar
    Photos working well both sending and receiving on iMessage between 2 iPhones 4s and 2 iPads ( one iPad 2 & one mini) All devices on iOS 6.1.3
    Location is Barbados, Carrier LIME, - tried using both Wifi as well as 3G for phones, no problems whatsoever :-)
    04-06-2013 01:18 PM
  19. Jaguarr40's Avatar
    Moved to iMessage Forum
    04-10-2013 09:58 AM
  20. wamadden4's Avatar
    I am having this problem too and I am on Verizon... I have an iPhone 5 jailbroken on iOS 6.1
    06-04-2013 09:42 PM

Similar Threads

  1. Replies: 2
    Last Post: 11-03-2012, 12:51 PM
  2. Replies: 3
    Last Post: 10-14-2012, 11:56 AM
  3. MMS' not being sent correctly
    By Steve-O in forum iPhone 4
    Replies: 3
    Last Post: 07-28-2009, 09:09 PM
  4. Replies: 1
    Last Post: 03-13-2009, 12:02 PM
  5. Warning to iDisk Users: Your Data May Not Be Safe
    By Rene Ritchie in forum iPhone 4
    Replies: 2
    Last Post: 11-21-2008, 11:00 PM
LINK TO POST COPIED TO CLIPBOARD