1. ght's Avatar
    Hoping someone here can help. I've spent a whole day trying to figure this out with no success.

    I got a new VZW iPhone 5. I gave my 4S to my wife. Everything went just fine with the 5, but the 4S (now assigned to my wife's number) keeps trying to activate iMessage and FaceTime using my number. I've reset network settings, rebooted the phone, tried turning iMessage and FaceTime on/off. Just about every trick anyone suggested on the Internet. All without success.

    Any ideas?
    11-10-2012 11:53 PM
  2. Just_Me_D's Avatar
    Does your wife have her own Apple ID that she uses with the 4S and for FaceTime and iMessage usage? If she has logged in with her own credentials, then FaceTime and iMessage should not be trying to use your information. I'm not sure if this will help, but it can't hurt to try. Go to Apple ID and update your mobile phone number. Afterwards, have your wife reboot her 4S.
    11-11-2012 12:08 AM
  3. ght's Avatar
    Thanks for responding. Yes, she has her own Apple ID. She can sign in with that and it will work using her email address, but the phone number appears to be stuck on my number, and just shows "waiting for activation". I did update the Apple ID site with her mobile number, but it doesn't seem to have helped.
    11-11-2012 12:37 AM
  4. Peligro911's Avatar
    What carrier do you have ?


    Beamed from my iPad 2 routed and bouncing across the globe on multiple servers and brought to you using Tapatalk !
    11-11-2012 12:56 AM
  5. Peligro911's Avatar
    I would restore the phone either way


    Beamed from my iPad 2 routed and bouncing across the globe on multiple servers and brought to you using Tapatalk !
    11-11-2012 12:58 AM
  6. bamf-hacker's Avatar
    When you go to the phone app does it show your number or hers?
    11-11-2012 01:02 AM
  7. ght's Avatar
    Phone app shows her number. Only iMessage and FaceTime seem to be stuck on my number.

    I'm on Verizon. It's jailbroken, so a restore would wipe that and force her onto iOS 6. Prefer to avoid that, and from what others have said on the Internet, a restore doesn't seem to fix this issue. I find that hard to believe, but I guess if Apple servers refuse to disassociate this hardware from my number, that could be the case.
    11-11-2012 10:12 AM
  8. Just_Me_D's Avatar
    I would again try logging out of iMessage and FaceTime, and then powering off the device. Wait about 30 seconds, power back on and then when after your service provider's logo appear, log into iMessage & FaceTime and see if it corrects itself.
    11-11-2012 10:29 AM
  9. ght's Avatar
    I tried that. I even went so far as to reactivate my phone number on the device and reactivate iMessage and FaceTime (which worked), log back out and deactivate both, then put her number back on the device, reset network settings, then tried to activate iMessage and FaceTime, but it still tries to use my number.
    11-11-2012 11:46 AM
  10. Peligro911's Avatar
    Long shot but
    Do *228 option 1
    11-11-2012 12:21 PM
  11. ght's Avatar
    Did that. At least twice. Maybe I'll just give it 24 hours and see if it somehow fixes itself.
    11-11-2012 01:29 PM
  12. Just_Me_D's Avatar
    Did that. At least twice. Maybe I'll just give it 24 hours and see if it somehow fixes itself.
    Do you have a Mac computer with Mountain Lion installed AND has iMessage & FaceTime configured using the phone number that you're trying rid from your 4S? If so, logout of the aforementioned features on your Mac, reboot it and then log back in and make sure your new number is listed along with your current Apple ID. Hopefully, that will somehow cake way for your wife's number to be configured for FaceTime & iMessage use on the 4S. It's a long shot, but hey, everything else has been tried.....
    11-11-2012 01:57 PM
  13. Peligro911's Avatar
    Only thing else I can think of is a restore

    If your jb you can save your blobs and make the ipsw to restore to same ipsw
    11-11-2012 02:19 PM
  14. ght's Avatar
    Nope. PC. These two phones are the only Apple devices our household has ever owned.
    11-11-2012 02:25 PM
  15. ght's Avatar
    I have blobs saved in Cydia and Tinyumbrella, but not sure what tool I'd use to restore as new to 5.1.1.
    11-11-2012 02:28 PM
  16. Peligro911's Avatar
    I have blobs saved in Cydia and Tinyumbrella, but not sure what tool I'd use to restore as new to 5.1.1.
    Redsnow you download 5.1,1 ipsw and stitch the blobs and do a shift restore in iTunes after starting the server in tiny umbrella
    11-11-2012 02:31 PM
  17. ght's Avatar
    Well, I managed to get the device registered in iTunes to her Apple ID. (It was still registered to mine.) Thought I was on to something, but the issue persists.
    11-11-2012 07:10 PM
  18. ght's Avatar
    Redsnow you download 5.1,1 ipsw and stitch the blobs and do a shift restore in iTunes after starting the server in tiny umbrella
    No dice. The update to 5.1.1 must have been OTA prior to my ownership. The redsn0w restore function can't work with OTA blobs.
    11-11-2012 07:11 PM
  19. Peligro911's Avatar
    Do you jailbreak for a unlock ?
    11-11-2012 07:12 PM
  20. ght's Avatar
    Nope. No need for unlock, just jailbreak functionality.
    11-11-2012 07:16 PM
  21. Peligro911's Avatar
    Nope. No need for unlock, just jailbreak functionality.
    Only option I see is if you restore and go to iOS 6 or wait to see if it fixes itself
    11-11-2012 08:24 PM
  22. ght's Avatar
    I'll just have to wait for a while. Maybe Apple's servers will straighten themselves out.
    11-11-2012 10:04 PM
  23. Peligro911's Avatar
    I'll just have to wait for a while. Maybe Apple's servers will straighten themselves out.
    Any luck ?
    11-13-2012 08:23 PM
  24. ght's Avatar
    Any luck ?
    Nope.
    11-13-2012 10:24 PM
  25. Peligro911's Avatar
    Nope.
    Think only option is restore my friend or turn it off
    11-13-2012 10:28 PM
32 12

Similar Threads

  1. Unable to use iMessage on de-activated 3GS?
    By Coffeegrower in forum iMessage
    Replies: 12
    Last Post: 06-27-2013, 01:29 PM
  2. Replies: 3
    Last Post: 02-19-2009, 01:37 PM
  3. Replies: 2
    Last Post: 07-11-2008, 01:49 PM
  4. trying to cancel new service problems
    By TwinTurbo350z in forum iPhone 4
    Replies: 22
    Last Post: 07-10-2007, 01:37 PM
  5. Guys tries to swipe iPhone..or mic?
    By bruckwine in forum iPhone 4
    Replies: 9
    Last Post: 06-30-2007, 01:08 AM
LINK TO POST COPIED TO CLIPBOARD