Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
  1. Thread AuthorThread Author   #1  
    Ziltoid's Avatar
    iPhone Beginner

    Posts
    53 Posts
    Global Posts
    59 Global Posts

    Default iMessage Delaying

    Hello everyone.

    Im having a weird issue that started last night and all day today with iMessage. When I send a message, it says "Delaying" on top and then it sends. It also gives you the chance to cancel, where the send button is. Ive never seen this before. I used to be able to just hit send and go back to my homescreen but I cant unless I actually wait until the message sends. If I hit send and click home, it will not go through. Anyone had this issue or know how to fix it?

    Ive rebooted, turned off the phone, turned off cell network. Turned on and off iMessage. I have no idea whats going on.

    Thanks!
  2. #2  
    JustMe'D's Avatar

    Posts
    22,049 Posts
    Global Posts
    22,283 Global Posts
    iOS Version
    7.0.4

    Default

    I don't have that problem with iMessage, however, I'm starting to believe that there are new issues with iCloud. Sending mail from my iPhone has been taking longer than usual when sending from my iCloud account.


    Just Me, D
    Tapatalk (iPhone 4S)
    Last edited by JustMe'D; 02-29-2012 at 02:12 PM.
  3. #3  
    sting7k's Avatar
    iMore Elite

    Posts
    2,691 Posts
    Global Posts
    3,523 Global Posts
    iOS Version
    7.0.2

    Default

    If all those things didn't work than it's likely something on Apple's end with the servers. I've not seen it ever say delayed. I have had messages not send, attempt to send for a long time and then switch to an SMS, and messages seemingly get "lost" for varying lengths of time and then get delivered.

    Personally I am not very confident in iMessage at this time. Hopefully it improves. I will say it seems to be most reliable when it is using an email address as the ID and not a phone number.
  4. Thread AuthorThread Author   #4  
    Ziltoid's Avatar
    iPhone Beginner

    Posts
    53 Posts
    Global Posts
    59 Global Posts

    Default

    Took a screenshot
    Attached Thumbnails Attached Thumbnails iMessage Delaying-img_0211.png  
  5. #5  
    naviwilliams's Avatar
    Distinguished

    Posts
    1,510 Posts
    Global Posts
    15,249 Global Posts
    iOS Version
    7.0.1

    Default

    I take it, it wouldn't have anything to do with being jailbroken, right?
  6. Thread AuthorThread Author   #6  
    Ziltoid's Avatar
    iPhone Beginner

    Posts
    53 Posts
    Global Posts
    59 Global Posts

    Default

    Quote Originally Posted by naviwilliams View Post
    I take it, it wouldn't have anything to do with being jailbroken, right?
    lol, negative. Ive had it jailbroken since it came out. This just started last night like I said and I havent changed, installed or modified anything.
  7. #7  
    naviwilliams's Avatar
    Distinguished

    Posts
    1,510 Posts
    Global Posts
    15,249 Global Posts
    iOS Version
    7.0.1

    Default

    Ah, well, maybe it is carrier related. I've been chatting with my Missus (AT&T, Atlanta) and my friend in Canada (not sure of her carrier), virtually all day, and it is working fine...

    Hmm, what about as a test you try it over WIFI only, and see how it acts?

    Lastly, close ALL conversations you have open, and then start a new one and see what gives...
  8. #8  
    Daveed84's Avatar
    iPhone Nanite

    Posts
    1 Posts

    Default

    I believe this is caused by xMessages (in your settings), as there was an update recently for it in Cydia.

    Go to Settings, xMessages, then toggle "Delay" to "Off".

    Not sure why they made it On by default.
    Thanked by:
    Todd M (03-02-2012)
  9. Thread AuthorThread Author   #9  
    Ziltoid's Avatar
    iPhone Beginner

    Posts
    53 Posts
    Global Posts
    59 Global Posts

    Default

    Quote Originally Posted by naviwilliams View Post
    Ah, well, maybe it is carrier related. I've been chatting with my Missus (AT&T, Atlanta) and my friend in Canada (not sure of her carrier), virtually all day, and it is working fine...

    Hmm, what about as a test you try it over WIFI only, and see how it acts?

    Lastly, close ALL conversations you have open, and then start a new one and see what gives...
    Ill try the Wifi option when I get home and report back. Ill also delete all the messages after that. Thanks.
  10. Thread AuthorThread Author   #10  
    Ziltoid's Avatar
    iPhone Beginner

    Posts
    53 Posts
    Global Posts
    59 Global Posts

    Default

    Quote Originally Posted by Daveed84 View Post
    I believe this is caused by xMessages (in your settings), as there was an update recently for it in Cydia.

    Go to Settings, xMessages, then toggle "Delay" to "Off".

    Not sure why they made it On by default.
    Boom! That was it. Very nice. Thanks a lot. Totally forgot about that update
  11. #11  
    naviwilliams's Avatar
    Distinguished

    Posts
    1,510 Posts
    Global Posts
    15,249 Global Posts
    iOS Version
    7.0.1

    Default

    See I TOLD YOU it was related to being jailbroken!

    I was right; yep, I was right
  12. Thread AuthorThread Author   #12  
    Ziltoid's Avatar
    iPhone Beginner

    Posts
    53 Posts
    Global Posts
    59 Global Posts

    Default

    Quote Originally Posted by naviwilliams View Post
    See I TOLD YOU it was related to being jailbroken!

    I was right; yep, I was right
    Haha! I guess you are.
  13. #13  
    Todd M's Avatar
    iPhone Newbie

    Posts
    38 Posts
    Global Posts
    409 Global Posts
    iOS Version
    5.0.1/5.1

    Default

    I was having the same problem and couldn't figure out why it happened. It was the xMessage app as described by Daveed84. Thanks!

Posting Permissions