Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By Peligro911
  1. Thread AuthorThread Author   #1  
    pamaf's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default Imessage problems

    My apologies if the topic has been posted already.
    I live in USA and my career is ATT, Both my wife and I have Iphone 4 updated to IOS 5. We use Imessage to communicate with my brother and my sister in law in Italy. They both have Iphone 4 updated to IOS 5. We all have Imessage on. We don't send International sms to any other phone or iphone.
    98% of the conversations are sent and received as Imessage (blue). Few of them start as an Imessage (blue) and, when sent, became International SMS (green).. It happens both in wi-fi or 3G. During the same conversation or different conversation. No matter if a pic is attached or just text. ATT is charging me $ for the international texting and this drives me crazy. Neither ATT nor Apple is providing an explanation. If I cannot find a solution I'll be forced to use third part apps (viber) to send international free sms from iphone to iphone

    Thanks in advance for your help and happy holidays to all!
  2. #2  
    hellomiggy's Avatar
    iPhone Intermediate

    Posts
    158 Posts
    Global Posts
    293 Global Posts
    iOS Version
    6.0 b.1

    Default

    If they have their Apple ID's (Email) as a second number on their devices, why not try sending an iMessage to their Phones. Email them first, just to see if they are connected with Apple ID and so it won't cost you money to send a text. If you go to Messages under the Settings Menu, it has an option to Receive At... mine has 2 addresses (Phone Number and Apple ID/Email).
  3. #3  
    Peligro911's Avatar

    Posts
    4,675 Posts
    Global Posts
    4,720 Global Posts
    iOS Version
    6 and 5

    Default

    I think there is a option to turn off if iMessage fails send as SMS so atleast that way you won't send SMS if iMessage fails and get charged


    Sent Into Orbit from my iPhone 4S using Tapatalk
    avmsam likes this.
  4. #4  
    The_colombian's Avatar
    iMore Beginner

    Posts
    78 Posts
    Global Posts
    100 Global Posts

    Default

    Send the message to their email instead of their number. Not sure if it will still try to send it to the phone number.
  5. #5  
    noaim's Avatar
    iMore Specialist

    Posts
    1,450 Posts
    Global Posts
    9,474 Global Posts
    iOS Version
    6.0

    Default

    Quote Originally Posted by Peligro911 View Post
    I think there is a option to turn off if iMessage fails send as SMS so atleast that way you won't send SMS if iMessage fails and get charged


    Sent Into Orbit from my iPhone 4S using Tapatalk
    This is correct there is a setting under settings messages


    Sent from my iPhone 4S using Tapatalk
    I answer questions to the best of my knowledge if im wrong please correct me
  6. #6  
    MECM's Avatar
    iPhone Intermediate

    Posts
    201 Posts
    Global Posts
    254 Global Posts
    iOS Version
    5.0

    Default

    Quote Originally Posted by Peligro911 View Post
    I think there is a option to turn off if iMessage fails send as SMS so atleast that way you won't send SMS if iMessage fails and get charged


    Sent Into Orbit from my iPhone 4S using Tapatalk
    I shut the SMS option off when I got my 4s, and I have never once had an iMessage fail. I don't text internationally, though.


    Sent from my iPhone using Tapatalk
  7. Thread AuthorThread Author   #7  
    pamaf's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default

    Thanks all! It looks like could be a Apple server problem.. I turned off "send as sms.." option.
  8. #8  
    noaim's Avatar
    iMore Specialist

    Posts
    1,450 Posts
    Global Posts
    9,474 Global Posts
    iOS Version
    6.0

    Default

    Quote Originally Posted by pamaf View Post
    Thanks all! It looks like could be a Apple server problem.. I turned off "send as sms.." option.
    no problem that should do the trick
    I answer questions to the best of my knowledge if im wrong please correct me

Posting Permissions

B