Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread AuthorThread Author   #1  
    iPhoneGleek's Avatar
    iPhone Intermediate

    Posts
    162 Posts

    Default iMessage not showing "Read"

    Me & my brother both have iPhone 4's and iOS 5 installed his iMessage works perfect for him. He can see when I read the message and when I'm typing. Mine only shows when he is typing it doesn't tell me if he read it or not it just says "delivered"
    I can figure out what to do..
  2. #2  
    Garz's Avatar
    Retired Moderator

    Posts
    4,932 Posts
    Global Posts
    13,860 Global Posts

    Default

    Quote Originally Posted by kkfasho View Post
    Me & my brother both have iPhone 4's and iOS 5 installed his iMessage works perfect for him. He can see when I read the message and when I'm typing. Mine only shows when he is typing it doesn't tell me if he read it or not it just says "delivered"
    I can figure out what to do..
    He needs to activate the "Read" in message settings
  3. #3  
    noaim's Avatar
    iMore Guru

    Posts
    1,558 Posts
    Global Posts
    9,590 Global Posts

    Default

    go to settings > messages > Send read receipts on
  4. #4  
    Appleshampoo's Avatar
    iPhone Newbie

    Posts
    40 Posts
    Global Posts
    41 Global Posts

    Default

    Yea unless the RECIPIENT turns on their read message you won't see it.

    Personally I keep it off because I don't always answer right away and people get mad of you read but didn't answer ASAP
  5. #5  
    BreakingKayfabe's Avatar
    iMore Genius

    Posts
    6,212 Posts
    Global Posts
    6,593 Global Posts

    Default

    I'm so glad we get the option to turn of read receipts. If we couldn't, I'd just turn off iMesaage completely.
  6. #6  
    paul-c's Avatar
    iMore Intermediate

    Posts
    206 Posts
    Global Posts
    1,528 Global Posts

    Default

    I really hate read receipts for work emails. Nice that the default is off for the iPhone.

Posting Permissions