Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread AuthorThread Author   #1  
    matrix2004's Avatar
    iPhone Newbie

    17 Posts
    Global Posts
    1,671 Global Posts

    Default Contacts not showing in icloud

    So i have contacts set to back up on icloud but when i go to the icloud website it shows zero contacts. Help?
  2. #2  
    Alli's Avatar
    iMore Genius

    10,934 Posts
    Global Posts
    13,726 Global Posts


    If you go to Settings and look at your iCloud account, are contacts checked?
  3. #3  


    Have you created an iCloud mail account? If so, your contacts should sync with iCloud. Also, like Alli stated, make sure that everything you want synced is set to ON in your phone's iCloud settings.
    Last edited by JustMe'D; 01-24-2012 at 08:19 PM.
  4. #4  
    Gabbi McCormick's Avatar
    iMore Nanite

    1 Posts

    Default Re: Contacts not showing in icloud

    I am having this issue and I have everything set correctly from what I can tell. I still have more contacts on my iPhone than what I see in iCloud. 157 on my iPhone and 63 on iCloud. I have deleted my iCloud account from my iPhone, restarted my iPhone and then added iCloud again (oh and reset on iCloud on my computer). This did not update/fix anything. Any suggestions?

  5. #5  

    Default Re: Contacts not showing in icloud

    If you have more than one email account configured on your device, make sure to correctly set the "primary" account by going to Settings->Mail, Contacts, Calendars and them scrolling down to "Default Account". Now, when you login to the iCloud website via a computer, are you viewing all contacts or just a certain group? Finally, make sure contacts is enabled in the iCloud settings on your device.

Posting Permissions