1. chrisoldroyd's Avatar
    I am not sure if this is an iPhone 5 issue or an iOS 6 issue but since getting my iPhone 5, GMail is not getting pushed to my device, mail only arrives when I open the Mail app. All of my settings are correct and the same settings work fine on my iPad 2. I have deleted and re-added the account, removed all mail accounts and added them back one by one, and now done a restore. Still exactly the same problem.

    Only option I can see is to set up as a new phone but that's going to be painful, anyone else having the same problem?

    Thanks
    Chris
    09-24-2012 07:41 AM
  2. spencer500's Avatar
    I am not having this problem. I am using an Iphone5 and have gMail setup through Exchange. Working perfectly.
    09-24-2012 08:12 AM
  3. chrisoldroyd's Avatar
    Weird, its driving me mad.
    09-24-2012 08:35 AM
  4. Just_Me_D's Avatar
    Nope. You've done what you needed to do except the main thing...reset and restore as new so you might as well get started and get it over with...
    09-24-2012 09:37 AM
  5. M.J.Clark's Avatar
    I was having issues with loading it as gmail, so I used exchange with the domain: m.google.com

    From there I was able to pick and choose what I wanted on my phone. I also cross connected the wife's calendar with mine so we have access to each others schedules.
    09-24-2012 02:25 PM
  6. BreakingKayfabe's Avatar
    Just restore as new without even setting up anything but the Exchange account. Then test it. If it works, then you know you fixed it with a restore. If it doesn't, you have your backup.
    09-24-2012 03:45 PM
  7. farb12's Avatar
    No problems here either, It's kind of funny I get my gmail email on my iPhone before I get on my Android devices.
    09-24-2012 05:36 PM
  8. chrisoldroyd's Avatar
    Restore and set up as new did not fix it, still the same problem. My proper Exchange account works fine, its just Gmail. The same account is pushing fine to my iPad.
    09-25-2012 08:31 AM
  9. SnapThrow's Avatar
    Restore and set up as new did not fix it, still the same problem. My proper Exchange account works fine, its just Gmail. The same account is pushing fine to my iPad.
    Confirm you have setup Gmail as an Exchange account? If you are setting up as a "Gmail" account then you will be on a "fetch" schedule (instead of "push") and there are four settings for that schedule -- every 15, 30, hourly and manually. I believe the default is manual so maybe that is the problem. Long story short -- setting up Gmail as an Exchange account is a much better way to go.
    09-25-2012 10:25 AM
  10. Highrisedrifter's Avatar
    I was having issues with loading it as gmail, so I used exchange with the domain: m.google.com

    From there I was able to pick and choose what I wanted on my phone. I also cross connected the wife's calendar with mine so we have access to each others schedules.
    Exactly this on my phone too. Push mail works perfectly with my Gmail account now using this method.
    09-25-2012 12:11 PM
  11. Jack7788's Avatar
    You're not alone. There is a problem with push mail on Exchange and Gmail on the iPhone 5. There is an evolving discussion here. https://discussions.apple.com/thread...rt=45&tstart=0. None of our enterprise users can get push mail to work at all on the iPhone 5. Driving us nuts.
    09-26-2012 04:36 PM
  12. rew001's Avatar
    I am not having this problem. I am using an Iphone5 and have gMail setup through Exchange. Working perfectly.
    This. I am now knocking on wood.


    Sent from my iPad using Tapatalk HD
    09-26-2012 04:58 PM
  13. JonB74's Avatar
    You're not alone. There is a problem with push mail on Exchange and Gmail on the iPhone 5. There is an evolving discussion here. https://discussions.apple.com/thread...rt=45&tstart=0. None of our enterprise users can get push mail to work at all on the iPhone 5. Driving us nuts.
    Same problem I have with iPhone 4s. Email is all but busted. Won't connect to the servers, extremely slow, won't load messages.
    09-26-2012 05:26 PM
  14. Just_Me_D's Avatar
    Same problem I have with iPhone 4s. Email is all but busted. Won't connect to the servers, extremely slow, won't load messages.
    Email is NOT busted. At least not for everyone. I, too, have an iPhone 4S and my gmail (configured via Exchange) is being pushed without a problem.
    09-26-2012 06:02 PM
  15. JonB74's Avatar
    Good for you - want a cookie?
    I was talking about MY phone not yours
    09-26-2012 07:56 PM
  16. Just_Me_D's Avatar
    Good for you - want a cookie?
    I was talking about MY phone not yours
    You know, I was responding to your remark that "email is all busted". I did not think that my response was inappropriate. Unfortunately, you appear to have taken it inappropriately. As for your question - Do you want a cookie? - No thank you, but thank you for offering. Hopefully, you will get your email problem solved soon. Sorry I wasn't much help. Take care and enjoy the rest of your evening...
    09-26-2012 08:37 PM
  17. mariarose7's Avatar
    Ok, I was having the exact same problem. iPad push working, iPhone 5 not so much. The only setting I found that was different for my iPad and iPhone 5 was within the iTunes in the 'Info' section of the sync settings on my computer. I had to uncheck the 'Sync Mail Accounts' for my iPhone and push services started back up. Hope this helps!
    09-27-2012 05:52 PM
  18. ame's Avatar
    My 4S is having the same issue. If I don't have the Mail app running I don't get email, no push, not at all, won't connect. I have deleted and re-setup my accounts, and I have completely reset the phone and started completely from scratch and still have the same issue.
    09-28-2012 03:49 PM
  19. piranhadonna's Avatar
    I was having this same problem with aol. I changed it to fetch instead of push. This fixed my problem.
    09-28-2012 04:50 PM
  20. rickydross's Avatar
    My Gmail account works fine but my work exchange email is broken.

    Just throwing my 2 cents in.
    10-25-2012 01:38 AM
  21. jimfam's Avatar
    I had the same problem. All you need to do is turn off all mail accounts except one. Then the fast loading begins. Must be a fault in running more than one.
    Almost seems like it gets confused on which mail account to use.
    12-07-2012 08:47 PM
  22. GibMcFragger's Avatar
    I have had GMAIL set to push via Exchange on my 4, my 4s and now my 5 and it has always worked flawlessly. I would double-check all your settings (exchange account settings) again and make sure you don't have anything incorrect.
    12-07-2012 10:21 PM
  23. NegroNapoleon's Avatar
    They also need to fix the fact that notification center doesn't work nicely with EXCHANGE GMAIL
    12-09-2012 03:19 PM
  24. TurboTiger's Avatar
    They also need to fix the fact that notification center doesn't work nicely with EXCHANGE GMAIL
    NN
    I have no issues with Notification Center Exchange Gmail.

    Good Luck
    12-09-2012 08:00 PM
  25. Just_Me_D's Avatar
    NN
    I have no issues with Notification Center Exchange Gmail.

    Good Luck
    Me neither.
    12-09-2012 08:18 PM
28 12

Similar Threads

  1. iCloud isn't pushing email on iOS 5
    By Greg_Elite in forum iOS 5
    Replies: 0
    Last Post: 10-04-2011, 10:51 PM
  2. Replies: 4
    Last Post: 04-07-2011, 06:18 PM
  3. Gmail exchange not pushing?
    By alpha752 in forum Google and Gmail
    Replies: 9
    Last Post: 03-05-2011, 02:47 AM
  4. Gmail and Corporate Exchange Mail Not Pushing
    By theswami in forum Google and Gmail
    Replies: 1
    Last Post: 02-20-2011, 12:01 PM
  5. Gmail imap not pushing
    By alpha752 in forum Google and Gmail
    Replies: 5
    Last Post: 02-15-2011, 06:51 PM
LINK TO POST COPIED TO CLIPBOARD