Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread AuthorThread Author   #1  
    ealvin's Avatar
    iMore Newbie

    Posts
    49 Posts

    Default Google Contacts

    I've synced my 3G to Google successfully using Google sync, however while my calendar and mail update, my contacts don't. I've recently modified my contacts sync info to use Google on itunes but that didn't seem to help. Any ideas?

    Thanks in advance for your help;
  2. #2  
    Massie's Avatar
    iMore Genius

    Posts
    5,015 Posts
    Global Posts
    5,020 Global Posts
    iOS Version
    8.0.2

    Default

    You're using Gmail set up as Exchange? Go to Settings>Mail, Contacts, Calendar and choose the account; make sure Contacts is toggled On. Go back to Mail, Contacts...scroll down to the Contacts section and make sure the default account used for new contacts is your gmail. If not set there, new contacts added on your phone won't sync to gmail automatically.
  3. Thread AuthorThread Author   #3  
    ealvin's Avatar
    iMore Newbie

    Posts
    49 Posts

    Default

    Thanks for your reply. I don't know if I'm using Google as an exchange or not. I assume I am, but I'm not totally sure. I'm certainly not using MS exchange.

    In my OS (4.2.1) I don't see a toggle for Contacts. Under Accounts, I have accounts for Gmail (mail, calendars) and Google (calendars) and Add Account.

    Under Contacts the only options I have are sort and display order.

    Also, I'm not sure if I've made this clear but I want to emphasize that I was successfully able to import the Contacts into my iPhone. I'm just not having any luck updating subsequent changes.

    Any ideas where do I go from here?
  4. Thread AuthorThread Author   #4  
    ealvin's Avatar
    iMore Newbie

    Posts
    49 Posts

    Default

    Thanks for your reply. I'm on IOS 4.2.1. I don't have a Contacts account to toggle. I only have a Gmail (calendars, mail) and a google.com account (calendars).

    I also want to reemphasize that I was able to setup and view my contacts -- but have not been successful in having updated contact info show in my phone.

    Any ideas?
  5. #5  
    Massie's Avatar
    iMore Genius

    Posts
    5,015 Posts
    Global Posts
    5,020 Global Posts
    iOS Version
    8.0.2

    Default

    You actually DO want to use MS Exchange...it doesn't mean you're using a Microsoft account or email, it's just the name of the syncing service. It's free, very easy to set up, and once you do that you can sync Contacts, Calendars, and Mail over the air. Read about it here: Daily Tip: How to setup Gmail as Exchange to push your e-mails [Beginner] | iMore.com

    I have all my gmail accounts set up this way and can't imagine ever using anything else.

    Here are the setup steps from the linked article:

    Launch the Settings app.
    Tap Mail, Contacts, Calendars.
    Tap Add Account.
    Tap Microsoft Exchange.
    For Email, enter your full Gmail or Google Account email address (i.e. name@gmail.com or name@mygoogleaccountdomain.com).
    Leave the Domain field blank. (Really.)
    Again, enter your Gmail or Google Account email address as the Username. (Yup, that's twice.)
    Enter your Gmail/Google Account password for Password.
    Tap Next.
    When the Server field appears, enter m.google.com.
    Tap Next.
    Select what you want to sync (Mail, Calendar, and Contacts).

    That's it!
    Thanked by:
    erwaso (10-16-2012)
  6. Thread AuthorThread Author   #6  
    ealvin's Avatar
    iMore Newbie

    Posts
    49 Posts

    Default

    Thanks. That did it.
  7. #7  
    Massie's Avatar
    iMore Genius

    Posts
    5,015 Posts
    Global Posts
    5,020 Global Posts
    iOS Version
    8.0.2

    Default

    Glad to help!
  8. Thread AuthorThread Author   #8  
    ealvin's Avatar
    iMore Newbie

    Posts
    49 Posts

    Default

    I've just noticed that after my most recent sync I now am not showing any contact phone numbers on my iPhone. They are all missing.

    After what I thought was a successful resolution to my initial problem in this thread, I started a new thead about how my iPhone Contacts were showing only one phone number per contact, even if two existed.

    Now this got me wondering if either or both of these issues could be related to adding the MS exchange sync but not undoing or removing my previous configuration using Google sync and/or having Contacts sync checked as the method of synching in iTunes.

    Anyway, that's where I am. Any ideas on fixing this? Thanks for any help you can give me.
    Last edited by ealvin; 08-13-2012 at 02:32 PM.
  9. #9  
    PT20's Avatar
    iPhone Nanite

    Posts
    2 Posts

    Default Re: Google Contacts

    1. "Fast Sync for Gmail Contacts" is a fast and simple way to sync Gmail & iPhone contacts .It is accurate and efficient. Requires iOS4.3 or later. Compatible with iPhone,iPad and iPod touch.

    Get "Fast Sync for Gmail Contacts" from AppStore:
    iOS App:
    http://itunes.apple.com/us/app/fast-...0l3Vy&ct=vb_im
    Mac OS X App:
    https://itunes.apple.com/cn/app/fast...0l3Vy&ct=vb_im

    2."Download Contacts for Google" is a quick and easy way to download Gmail contacts into iPhone, iPad & iPod touch.

    Get "Download Contacts for Google" from AppStore:
    http://itunes.apple.com/us/app/downl...0l3Vy&ct=vb_im

Posting Permissions