Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread AuthorThread Author   #1  
    willxcore's Avatar
    iPhone Nanite

    1 Posts
    Global Posts
    127 Global Posts

    Default Help: iPhone sends mail as different name than Gmail (same account)

    Small issue I'm running into that I can't seem to find a fix for. My Gmail account is set up on the web to send email as my full name 'First Last'. However, there doesn't seem to be any options for such a setting on the iPhone itself and whenever I send email from the same email address from the iPhone it sends as 'wxc' (my email address is wxcore at gmail)

    Sometimes I send work to recipients at my office and it's a little annoying and somewhat unprofessional to send email as simply 'wxc'. How do I go about fixing this? Why would the iPhone decide on its own what to send mail as?

    I have Gmail setup as an exchange account on my phone, btw.
  2. #2  
    sting7k's Avatar
    iMore Elite

    2,963 Posts
    Global Posts
    3,874 Global Posts


    I don't really understand.

    When someone gets and email from you that you sent on the iPhone it is displaying as "From:wxc" and not your name or address?
  3. #3  
    big9erfan's Avatar
    iMore Elite

    2,454 Posts
    Global Posts
    2,455 Global Posts


    Wish I could help you but I have no problems with it working as it is supposed to. Have you tried deleting and recreating the account?
  4. #4  
    riteshp83's Avatar
    iMore Newbie

    22 Posts


    Go to settings, mail, select the account, account, and under the name, change it to your full name. That should resolve your problem.
    Alli likes this.

Tags for this Thread

Posting Permissions