Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread AuthorThread Author   #1  
    mmalsn's Avatar
    iPhone Newbie

    11 Posts

    Default About xcode

    i have os lion 10.7 and xcode version 3.2.5 I installed the xcode but there is something wrong I can't see the xcode shortcut ,
    I search for this problem and i saw something like xcode 4.1 preview 4
    this for lion , if true should i be associate with developer program ,

    help me please?
  2. #2  
    tengence's Avatar
    iPhone Newbie

    17 Posts


    you might want to upgrade your ver to 4.1, its free in the app store and yes you need to be associated with the developer program. You could register for free and not pay, you just have to pay to if you want to test your apps on a real device or submit your apps to the appstore. But for just learning on the simulator its free. You will have to completely remove your current ver of Xcode before you install the new one though otherwise you might get linking errors with you try and compile your code.

    In order to do the uninstall you have to type in 'sudo /Developer/Library/uninstall-devtools –mode=all' with out the " ' " into a terminal window. Let me know if you need anymore help ok?
  3. #3  
    LittleBitStudio's Avatar
    iPhone Newbie

    20 Posts


    Hi malsn,

    I've gotten 3.2.6 running on my Lion install, mainly because one of our apps won't build in XCode4. In order to get it working, I had to modify the image bundle to a read-write bundle and then edit one of the files in it before installing.

    Here's a quick run down of what I did:
    Open disk utilities and converted the dmg to a read-write bundle so it can be modified.
    Mounted the new read-write image and then edited the iPhoneSDKSL.dist in Contents
    I replaced the reference to 10.7 with 10.8

    Then I ran the install from it like normal. This time it installed and could be located like normal.

    Hope it helps. Theres a few articles around that you might want to google to verify as well. I literally just had to do this last night.

    Good Luck,
    Scott, LittleBitStudio

Posting Permissions