1. iMore Question's Avatar
    i have a ipod 5 gen
    11-06-2016 02:10 PM
  2. Tartarus's Avatar
    The safest way is to try and download those apps. If you tap on the apps in AppStore, there is an "information" field where it says what iOS version you should at least have running to use that app.

    Good luck. If you have any further questions, please join our forum. We're happy to help.
    11-06-2016 02:30 PM
  3. BlackNightmare's Avatar
    Not necessarily. Surely, some features, introduced with latest iOS versions, may not be supported or function, but you can download the app nonetheless. Concerning current app versions, Kik offers support for iOS 7 and newer versions, while Snapchat and Instagram instead need iOS 8 to be installed. If your device is on an older OS, you may still download an older version of the app (if, before being updated, they had an older version supporting your current OS), you just need to have them in your purchase list (if you don't, as they are free apps nonetheless, just open iTunes on a PC, use the same account you use on your device to login an do download them). If you tap on the cloud icon next to the app name, you will be prompted to download an older vesion instead of the newest (the last version that supported your iOS)
    11-06-2016 02:30 PM

Similar Threads

  1. How do i wipe my iphone 6s clean
    By iMore Question in forum Ask a Question
    Replies: 5
    Last Post: 02-21-2017, 05:44 PM
  2. How do I turn the color back on my I phone 5?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 11-07-2016, 01:26 AM
  3. Replies: 3
    Last Post: 11-06-2016, 05:33 PM
  4. how do I manually back up my mac to iCloud
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 11-06-2016, 01:41 PM
  5. Replies: 1
    Last Post: 11-06-2016, 01:26 PM
LINK TO POST COPIED TO CLIPBOARD