Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply
Results 1 to 4 of 4
  1. Thread AuthorThread Author   #1  
    iMore Question
    iMore Question's Avatar
    Guest

    Default My iPad doesn't offer an update past 5.1 and I need an iOS 8

    My iPad has a iOS 5.1 and I need at least an 8 to even download apps. How do I do that since my iPad or iTunes does not offer it
  2. #2  
    JB184351's Avatar
    iMore Newbie

    Posts
    48 Posts

    Default Re: My iPad doesn't offer an update past 5.1 and I need an iOS 8

    which iPad do you have?
  3. #3  

    Default Re: My iPad doesn't offer an update past 5.1 and I need an iOS 8

    If you have the original iPad, you will NOT be able to upgrade past iOS 5.1.1. You will need to purchase an iPad model newer than the original in order for you to enjoy certain features and apps.
  4. #4  
    Honey Beagle's Avatar
    iMore Elite

    Posts
    2,567 Posts

    Default Re: My iPad doesn't offer an update past 5.1 and I need an iOS 8

    Sometimes on my iPad first generation there are some applications that will have a version that is compatible with iPad 1.

Similar Threads

  1. Why did my pokestops stop giving balls?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 08-07-2016, 08:03 PM
  2. Why are my text messages popping up then going away?
    By iMore Question in forum Ask a Question
    Replies: 3
    Last Post: 08-06-2016, 06:42 PM
  3. How can I send and receive SMS text messages from my iMac?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 08-06-2016, 05:47 PM
  4. How to use Stories and Discover on Snapchat
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-06-2016, 05:00 PM

Posting Permissions