1. iMore Question's Avatar
    I restored my device and when I tried to activate it ,it keeps saying the activation server is down but then when I plugged it into itunes, it shows my device is connected,then when I press on the device logo it just shows a white blank page with the word 'Iphone' in the middle. I've tried everything from restartign my laptop,updatign Itunes,turning off phone etc and it's the same. HELP
    08-05-2016 06:04 AM
  2. Just_Me_D's Avatar
    1. Although, your Wi-Fi connection may be operating correctly, it's possible that your internet connection may not be available. Having said that, try rebooting both your Wi-Fi router AND your cable/DSL/Dial-up modem.
    2. Apple could be experiencing problems on their end. If so, give it time to correct the problem.
    08-05-2016 07:26 AM

Similar Threads

  1. Replies: 2
    Last Post: 08-12-2016, 05:56 PM
  2. Auto fill is missing on my ipad
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 08-05-2016, 11:09 AM
  3. Why am I limited with an iCloud music library playlist?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 08-05-2016, 06:17 AM
  4. why my device is not supporting SIM
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 08-05-2016, 01:51 AM
  5. Here's why Niantic Labs shut down third-party Pokemon trackers
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-04-2016, 09:22 PM
LINK TO POST COPIED TO CLIPBOARD