1. JobSteves's Avatar
    So Just the other day Safari stopped loading any sort of webpage on my iPhone.

    Have you ever had faulty Wi-Fi that sometimes doesn't work until you reset the router? Well that's exactly what it's like for me. However I've tried that it didn't work, and even my LTE doesn't work. Oh and everything else that uses Internet (tweetbot, Instagram, pandora etc.) work just fine.

    I've cleared all the data, I've deleted it from multitasking, I have done a hard reset, nothing works. However it only does this with Safari, when I use other third-party browsers the websites load just fine.

    So I'm just curious if anyone has any remedies for this other then restoring my phone because I don't want to lose my jailbreak.
    01-14-2015 09:06 AM
  2. Just_Me_D's Avatar
    Wow. Interesting. Have you checked the restrictions settings? Go to Settings - General - Restrictions - (enter your passcode), and then scroll down to the "Allowed Content" section and then make sure that "All" is selected next to "Websites".

    Alternatively, you can try resetting the network settings or checking your router or firewall configuration to see if Safari has been blocked from accessing the internet.
    01-14-2015 09:24 AM
  3. kch50428's Avatar
    Try resetting network settings.
    01-14-2015 09:24 AM
  4. JobSteves's Avatar
    Wow. Interesting. Have you checked the restrictions settings? Go to Settings - General - Restrictions - (enter your passcode), and then scroll down to the "Allowed Content" section and then make sure that "All" is selected next to "Websites".

    Alternatively, you can try resetting the network settings or checking your router or firewall configuration to see if Safari has been blocked from accessing the internet.
    Thanks for the advice. However I don't have restrictions turned on, and I've tried everything else you suggested and the screen just sits likes this for an in infinite amount of one.
    01-14-2015 09:45 AM
  5. JobSteves's Avatar
    01-14-2015 09:46 AM
  6. Just_Me_D's Avatar
    Thanks for the advice. However I don't have restrictions turned on, and I've tried everything else you suggested and the screen just sits likes this for an in infinite amount of one.
    Well, it might be a good time to restore your device and set it up as new. Oh, speaking of restoring, just in case it's a bad / corrupted setting, try going to Settings - General - Reset and then select "Reset All Settings". This action will NOT erase the contents of your device. All settings will simply revert to their default.
    01-14-2015 09:48 AM
  7. JobSteves's Avatar
    Well, it might be a good time to restore your device and set it up as new. Oh, speaking of restoring, just in case it's a bad / corrupted setting, try going to Settings - General - Reset and then select "Reset All Settings". This action will NOT erase the contents of your device. All settings will simply revert to their default.
    Again thanks. I reset all settings and now every time I open Safari it instantly puts the device into sleep mode. I was afraid that the only option would be to restore my phone and since I don't want to lose my jailbreak I'll just continue to use a third-party browser regardless of the fact that I like Safari better.
    01-14-2015 11:24 AM
  8. Just_Me_D's Avatar
    Again thanks. I reset all settings and now every time I open Safari it instantly puts the device into sleep mode. I was afraid that the only option would be to restore my phone and since I don't want to lose my jailbreak I'll just continue to use a third-party browser regardless of the fact that I like Safari better.
    I totally overlooked the fact that your device is jailbroken. That or a jailbreak app or setting is more than likely the culprit, but I'm only guessing. I don't and have never jailbroken any of my iOS devices.
    Sherry_B likes this.
    01-14-2015 11:47 AM
  9. JobSteves's Avatar
    Yup. As soon as I posted last I was kicking myself for not thinking of the most obvious. I installed a tweak the other day. I just uninstalled it and BAM! Everything is back to normal.
    Just_Me_D and Sherry_B like this.
    01-14-2015 01:41 PM
  10. Just_Me_D's Avatar
    Yup. As soon as I posted last I was kicking myself for not thinking of the most obvious. I installed a tweak the other day. I just uninstalled it and BAM! Everything is back to normal.
    Nice, and I'm glad you got it all working again. Thanks for the update, and enjoy the rest of your day...
    01-14-2015 01:43 PM
  11. kch50428's Avatar
    Yup. As soon as I posted last I was kicking myself for not thinking of the most obvious. I installed a tweak the other day. I just uninstalled it and BAM! Everything is back to normal.
    Now... for the benefit of other fellow users who jailbreak - mind naming the tweak so others can avoid it??
    01-14-2015 01:54 PM
  12. IconoclastHumanist's Avatar
    Had this happen once, on my iPhone still "in jail". I had Safari cellular data disabled and a good wifi connection, yet Safari was claiming I had "no internet connection".

    Killing and restarting Safari did not help.

    Killing Safari, then turning off wifi, and turning it back on, then restarting Safari, did not help.

    I killed Safari, selected Airplane Mode, then went back to normal mode, then opened Safari. PROBLEM SOLVED! Not sure if this is just a one-time coincidence; no chance to repeat so far.

    Looks like somehow Safari got into a funny mode where it ONLY used cellular data, even when wifi was good...which might explain why my data use is higher than I would expect. NOT HAPPY about the possibility Safari was chewing through a lot of cellular data when wifi would have been available for free!
    11-26-2015 12:49 AM
  13. sprout1958's Avatar
    My phone has been doing the same thing. If I clear out all the open web pages it works fine. I've never had this problem before but as long as I keep it cleaned out it works fine.
    03-16-2016 08:13 PM
  14. CHIYING's Avatar
    It worked!!! Thank you So Much!
    08-11-2016 09:33 PM

Similar Threads

  1. Where can I find the ability to configure facebook on my iphone 5?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 01-14-2015, 09:29 AM
  2. Replies: 3
    Last Post: 01-14-2015, 09:14 AM
  3. Replies: 3
    Last Post: 01-14-2015, 08:18 AM
  4. Ipad stuck on startup not charging?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 01-14-2015, 07:58 AM
  5. Replies: 0
    Last Post: 01-14-2015, 04:51 AM
LINK TO POST COPIED TO CLIPBOARD