1. Steve Penny's Avatar
    I bought my first Apple TV at the weekend (all software updated) and have been using the apps without a problem. Unfortunately, when I try to either mirror or extend my desktop from me L2013 rMBP (Yosemite PB) I get massive lag. I'm using an AirPort Extreme which is right next to the Apple TV and TV itself (new Samsung and software is up to date), and my MBP is about 6 feet away.

    Any ideas/suggestions on potential fixes? Thanks!
    10-02-2014 12:24 PM
  2. pkcable's Avatar
    I'm not familiar with your router in particular, BUT I do know them a little. Perhaps you are having some bandwidth issues due to interference from your neighbors? You might need to go in to the router's settings and change the channel it is broadcasting on. Your neighbor may be using the same channel and this could be causing issues. Ideally you would use a network analyzer to evaluate the airwaves and pick the best channel, but its unlikely that you have one. So just keep trying. You either access the router with a special program that came with the router, OR by entering http://192.168.1.1 (USUALLY) in your browser. You will have to enter the username and password for the router,this will be either set by you, or provided in the router's docs, SOMETIMES it is written on a tag on the side of the router.
    10-03-2014 08:45 AM
  3. acerace113's Avatar
    Try a wired connection.


    Sent from my Surface 2 using Tapatalk
    pkcable and LockOnTech like this.
    10-03-2014 01:57 PM
  4. Steve Penny's Avatar
    I have tried all of the standard troubleshooting issues, as well as moving the APE radio on to 5ghz and changing the channel, but I'm still encountering the issue.
    I have also just tried a wired connection and the Mac can no longer find/connect to the Apple TV.
    11-29-2014 01:13 AM
  5. pbehnke2003's Avatar
    Try changing your default resolution to 720p. I know you are sacrificing some quality, but that is what I did for lag issues and it fixed any issue that I had!
    12-06-2014 12:26 PM
  6. Steve Penny's Avatar
    Didn't help, unfortunately.
    01-04-2015 10:10 AM
  7. knotsure's Avatar
    I am also having lag when mirroring videos from my ip6+. I was thinking maybe I need a new router anyways. The one I have I installed 4-5 yrs ago.
    01-07-2015 06:36 PM
  8. pbehnke2003's Avatar
    I think the ESPN app stinks...one thing I tried when I ordered the UFC app was reminded it a couple minutes so the buffering would have a chance to stay caught up..,I was 3 minutes behind on the Jon Jones fight but it worked pretty good.
    01-10-2015 10:55 AM
  9. pkcable's Avatar
    Time for a Chromecast?
    02-02-2015 10:26 AM
  10. shakson's Avatar
    just turn off bluetooth when using Mirroring and everythings gonna go smooth
    08-31-2016 04:44 AM

Similar Threads

  1. Replies: 3
    Last Post: 10-03-2014, 06:50 AM
  2. iPhone Camera Issue
    By forbiddens in forum iPhone 6
    Replies: 2
    Last Post: 10-02-2014, 12:21 PM
  3. Spotify finally gets on board with Apple CarPlay
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-02-2014, 06:40 AM
  4. The first third-party Apple CarPlay systems are here from Pioneer
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-02-2014, 06:12 AM
LINK TO POST COPIED TO CLIPBOARD