Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread AuthorThread Author   #1  
    TheBiggmann's Avatar
    iPhone Beginner

    59 Posts
    Global Posts
    101 Global Posts

    Default Can't update ATV2

    So last night around 2:30AM i went to try and upgrade my ATV2 to OS 5.0. I tried multiple times and every time I do it stays on the "estimating download time" stage, and after about 3 minutes says "The Apple TV could not be downloaded at this time. Try again later." I've been trying intermittently for 24 hours with no luck at all, and know friends who it is working just fine for. I tried unplugging the ATV for a while and then trying to update, doing a full restore, nothing. Anyone else have this issue?
  2. #2  
    verwon's Avatar
    iMore Pro

    645 Posts
    Global Posts
    4,312 Global Posts


    I finally gave up and used iTunes to update it, with a micro USB cable.

    Sent from my iOS ecosystem!

Posting Permissions