Welcome to the iMore Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
  1. Thread AuthorThread Author   #1  
    jvwong96's Avatar
    iPhone Newbie

    Posts
    22 Posts
    Global Posts
    51 Global Posts

    Default Netflix streaming issues since 4.2.1 update

    Hey I wanted to know if anyone else is having issues streaming content from Netflix since the 4.2.1 update for the Apple TV. I was trying to stream Nip/Tuck season 2 and most of the episodes won't load but other movies will. I can stream it just fine from my computer, iPad, and iPhone 3gs. I just wanted to know if my issue is isolated or if others are experiencing the same problem.
  2. #2  
    Mustang5Oh's Avatar
    iMore Expert

    Posts
    891 Posts

    Default

    I just got my Apple TV this afternoon and I updated the software and used Netflix without an issue. It was blazing fast too compared to other Netflix streaming devices.

     iPhone 5S - 64GB Space Grey
     iPad Mini - 32GB Black
     Apple TV 2nd Gen
     MacBook Pro - 250GB Aluminum Unibody
  3. #3  
    Mark511's Avatar
    iPhone Newbie

    Posts
    36 Posts

    Default

    Quote Originally Posted by jvwong96 View Post
    Hey I wanted to know if anyone else is having issues streaming content from Netflix since the 4.2.1 update for the Apple TV. I was trying to stream Nip/Tuck season 2 and most of the episodes won't load but other movies will. I can stream it just fine from my computer, iPad, and iPhone 3gs. I just wanted to know if my issue is isolated or if others are experiencing the same problem.
    Before the update Apple Tv was working great it was streaming very nicely from netflix and from itunes. Now since the update yesterday it is running very slow from Netflix, it told me a couple of times it couldn't connect with Netflix. Also Airplay on my iphone 4 is very buggy. sometimes it works and sometimes it doesn't, it will also shut off my WiFi on my phone.

    Overall very buggy update so far, not happy with it.
    iPhone 5 Black and Slate 16GB
    iPhone 4s Black 16GB
  4. #4  
    Rene Ritchie's Avatar
    iMore Actual

    Posts
    1,813 Posts
    Global Posts
    2,375 Global Posts
    iOS Version
    5.1

    Default

    Working fine for me but I know Georgia is having Netflix issues. Plays for a few seconds then throws up an HDCP warning.
  5. #5  
    Newliberty26's Avatar
    iPhone Nanite

    Posts
    4 Posts
    iOS Version
    5.1

    Default

    I am having trouble with my Netflix also. Before the update everything was fine and now, when I try to play anything HD, it takes forever to start. After it finally does start, it runs for about 15 seconds, pauses, and then continues in what seems like standard def. When I try to play standard def shows or movies, it will start rather quickly. I don't have any idea why it would do this.
  6. #6  
    GBraddock81's Avatar
    iPhone Nanite

    Posts
    5 Posts

    Default NETFLIX/APPLETV = Me Going Insane

    ok, i've called netflix 3 times in 2 days, comcast and apple. they're all blaming each other.

    the problem? netflix either takes FOREVER to load or constantly freezes during playback OR BOTH. It's unbearable to watch anything, tv shows or movies. i've shut down the network, created it's own network and nothing, still horrible playback.

    I'm going insane and not one of these companies is prepared to offer me any help.

    Greg

    iPhone 4
    iPad
    Apple TV
    13" MacBook Pro
    15" PowerBook G4
  7. Thread AuthorThread Author   #7  
    jvwong96's Avatar
    iPhone Newbie

    Posts
    22 Posts
    Global Posts
    51 Global Posts

    Default

    The work around fix I've been using is powering off the ATV and powering it back on. Netflix then works just fine until the next hiccup. I've noticed netflix having some issues on my Windows Media Center PC as well from time to time but it still is less often then what happens on my ATV. Here's waiting for iOS5 so it fixes this issue.
  8. #8  
    TampaDude's Avatar
    iPhone Intermediate

    Posts
    306 Posts
    Global Posts
    639 Global Posts

    Default

    Just updated mine to 4.2.1 last night. Netflix still works great.

    Can't wait for the untethered JB for 4.2.1 so I can JB this sucker.
  9. #9  
    darrylsaladino's Avatar
    iPhone Newbie

    Posts
    10 Posts
    Global Posts
    12 Global Posts

    Default

    I updated the software and used Netflix without an issue. It was blazing fast too compared to other Netflix streaming devices.
  10. #10  
    bammer05's Avatar
    iPhone Nanite

    Posts
    1 Posts
    Global Posts
    55 Global Posts

    Default

    Almost 1/2 of the content is gone from Netflix, say you go to Documentaries, there used to be 5 or 6 different categories, now there are only 2, is there something I do not know here? Do I need to do something to my Netflix acct or are any of you noticing this also
  11. #11  
    Nycegye's Avatar
    iPhone Newbie

    Posts
    13 Posts

    Default

    I've had a bunch of problems with NetFlix still even after the updated application. Not I'm not sure if it is my phone, but I highly doubt it is. ALso, why can't we just be able to watch every movie? It seems like it decreases the amount of movies each time I login....COme On Man!
  12. Thread AuthorThread Author   #12  
    jvwong96's Avatar
    iPhone Newbie

    Posts
    22 Posts
    Global Posts
    51 Global Posts

    Default

    How wonderful, now I can only stream movies and no tv shows on my ATV. This is getting kinda crappy. I'm watching more netflix on my computer and iPad than my ATV due to the streaming problem.

    I can't wait to see if the next update fixes this problem, in the mean time I guess I'll be stuck watching movies
  13. #13  
    jrpierce's Avatar
    iMore Newbie

    Posts
    41 Posts

    Default

    The only real issue I've noticed is that Netflix drops the sound pretty frequently. I usually watch say an episode of a tv show ore day and it's been a while since I've gone through one without having to pause/rewind to get the sound to come back in.

Posting Permissions